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Welcome to Adams 2024.2

Thank you for purchasing Adams 2024.2. Adams is motion simulation software for analyzing the complex 
behavior of mechanical assemblies. With it, you can test virtual prototypes and optimize designs for 
performance, safety, and comfort, without having to build and test numerous physical prototypes.
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About Hexagon

Overview

Hexagon is the leading global provider of virtual product development (VPD) tools, including simulation 
software and professional services. Hexagon helps companies make money, save time, and reduce costs 
associated with designing, testing, producing, and supporting manufactured products.

Hexagon works with thousands of companies worldwide, in hundreds of industries, to develop better 
products faster by using information technology, software, and services to enhance and automate the 
product design and manufacturing process. Simulating your product performance reduces development 
costs, time to market, and warranty costs. 

About Virtual Product Development and Adams

You’ve heard it before: manufacturing companies today face intense global competition, demanding 
customers, fragmented markets, increasing product complexity, compressed product cycles, price and 
profit pressures, strict regulatory and liability environments, systems integration and supply chain issues, 
skyrocketing costs of testing and physical prototyping, and on and on…

What you don’t often hear, though, is a strategy for enabling your company to improve your new product 
development process to meet these challenges. 

Whether you are delivering airplanes, automobiles, ships, biomedical devices, golf clubs or children’s toys 
to your customers, Hexagongoal is to help you improve your new product development process, allowing 
you to be significantly better at your concept development, design, testing, and production activities 
through the application of VPD. 

VPD is an environment that uses an integrated combination of both simulation software technology and 
traditional techniques to design, test, manufacture, and support products. The result is that cost-effective 
designs that meet all performance, safety, durability, and reliability requirements can be brought to market 
in less time and for less cost.

Adams, as part of VPD, is focused on enhancing your ability to make better product development decisions, 
explore innovative design alternatives, and consistently get the product right. It is the world's most widely 
used mechanical system simulation software. It enables you to produce virtual prototypes, realistically 
simulating the full-motion behavior of complex mechanical systems on your computers and quickly 
analyzing multiple design variations until an optimal design is achieved. This reduces the number of costly 
physical prototypes, improves design quality, and dramatically reduces product development time.

Preface   
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Technical Support

For help with installing or using an Hexagon product, contact Hexagon technical support. Our technical 
support provides technical assistance on questions related to installation and use of the software. For 
further details please see the Technical Support Usage Guide, which is accessible via our support web site.

You can reach Hexagon technical support on the web, by telephone, or e-mail.

Web

Go to the Hexagon web site at www.hexagon.com, and click on Support, then Manufacturing Intelligence, 
then Design and engineering support. Here, you can find a wide variety of support resources including 
Product Updates, Discussions, Technical Articles, and Documentation updates.

In addition, we provide several excellent sources of online information:

● SimCompanion: Find solutions to problems in this repository of troubleshooting tips, examples, and 
frequently asked questions. To access the SimCompanion, go to:
https://simcompanion.hexagon.com/

● VPD Community: The VPD community is where to go when you are looking for peer support, as well 
as technical expertise. Many of our consultants, developers, and technical support staff monitor the 
forums. To sign up for the forums, go to Adams Support Home Page.
Then,

● To view the Adams discussions, select Adams from the Forums menu.

 

● To view product alerts and company news and events, select Product Updates.

 

Phone and Email

For a current list of phone numbers and language based email addresses please visit our support web site. 

Training

Hexagon training provides comprehensive training in Virtual Product Development. We offer standard and 
customized training courses in the application of CAE tools to solve from basic to complex problems within 
any industry. We offer over 100 courses in our state-of-the-art classroom facilities and individual computer 

Preface   
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graphics laboratories at training centers throughout the world. All of our courses emphasize hands-on 
computer laboratory work to facilitate skills development. We are uniquely positioned to optimize your 
investment in design and simulation software tools.

Our industry experienced expert staff is available to customize our course offerings to meet your unique 
training requirements. For the most effective training, we also offer many of our courses at our customer's 
facilities.

We specialize in customized training based on our evaluation of your design and simulation processes, 
which yields courses that are geared to your business. In addition to traditional instructor-led classes, we 
also offer video courses, interactive multimedia training, web-based training, and a specialized instructor's 
program. 

Course Information and Registration

For detailed course descriptions, schedule information, and registration call the Training Specialist at +1 
800 426-1066 or visit www.hexagon.com.
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General

Issue Resolved 19

Issue Resolved

ADMS-113926
Wrong description for option NODAMPIN in LINEAR command for FORTRAN 
Solver

ADMS-113713 Adams Help says Import CAD density instead of Ignore

ADMS-112480 PTCV constraint typo

ADMS-110038
Frequency Bushing Stiffness and Damping are represented by letters 'C' and 'd' 
respectively instead of 'K' and 'C' in Adams help documentation

ADMS-103901 Linux Software Dependencies missing in Adams install guide
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Adams Car

Testrig Subsystems 20

Event Pre- and Post-Actions 21

Variant Improvements 21

Reordering Variants 22

Leafspring Support for True Batch Mode 22

Issues Resolved 23

Known Issues 26

 Testrig Subsystems

Changes to testrig hardpoints and parameters can now be saved to subsystem files. These subsystems 
can have variants, allowing for greater flexibility when working with testrigs:
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Event Pre- and Post-Actions

Simulation Events in Adams Car now allow for pre- and post-actions. These are used to execute custom 
logic before or after the simulation Event. Scripting commands can be written in either cmd language or 
Python and may be stored ‘inline’ with the model or as file references. Access this functionality by right-
clicking an Event in the Event Browser, as shown:

This new dialog box makes it easy to associate custom actions with specific events and to test these 
commands before applying.

Variant Improvements

Identifying the active Assembly and Subsystem variants is simpler now, as the variant name is displayed in 
both the display window and the Model Browser, as shown:
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Reordering Variants

The order in which variants are presented can now be controlled using the Reorder Assembly Variants 
menu:

Leafspring Support for True Batch Mode

Previously, running Adams Car in batch mode without a valid graphical display (ex: a Linux compute node 
lacking graphics display libraries) would cause errors when trying to change/regenerate some models 
containing leafsprings. It is now possible to regenerate leafsprings in a vehicle model in batch mode 
whether a valid graphical display environment exists or not.
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Issues Resolved

ADMS-115553
Error message when user specified the more than one node on flexbody for 
attachment

ADMS-114792 Suspension Analysis Tutorial not updated since the Setup menu change

ADMS-114785 Wrong type when selecting Analyses when importing Plot Template

ADMS-114697 Group activity expression isn't evaluated prior to communicator matching process

ADMS-114470 Adams Car automatically terminates after running the driving analysis

ADMS-114386
If your subsystem is in TeimOrbit format, subsystem variants may not work with a 
General Spline if it contains a COMMENT block.

ADMS-114265
Adams Car 'Demo_Vehicle_Variants.asy' assembly with "Open all subsystems in 
session" toggle button fails to open.

ADMS-113977
Environment variable MDI_ACAR_ANL_LOG conflicts with Adams Car Preferences 
feature

ADMS-113976
Environment variables in the config file of a plugin are saved to the personal 
.acar.cfg file.

ADMS-113789 Model Auditor issues error messages for non-Car bushings.

ADMS-113725

The "Beam Calculator" for torsional springs in Car fills the stiffness and damping 
fields using a values per radians instead of per degrees, regardless of modeling 
units, and the materials drop-down only contains 2 choices (steel and aluminum).

If you used that wizard to calculate stiffness and damping values for your torsional 
springs, please double-check those numbers in your subsystems (they could be too 
high by a factor of 57.3).

ADMS-113563
issue with Adams re-attaching markers on flex bodies despite explicityly setting the 
option preserve_location = true

ADMS-113520
Documentation for Request 907 within the Appendix does not match the Reviewing 
Results > Requests section

ADMS-113493
Error message appears when opened "Create Joint Motion Actuator" dialog box in 
template builder

ADMS-113468
MSC_ADAMS_SD_CENTERLINE_SPACING, MSC_SD_SDB_MIN_ITERATIONS 
and MSC_SD_PATH_CLOSED environment variables documentation is missing

ADMS-113351
For gse based powertrain, the powertrain configuration design option (pvs_
powertrain_config) documented in Adams online help however it is missing from the 
template

ADMS-113138 Documentation missing for the details of the "Lock" option in SPMM

ADMS-112976
In Adams Car, after a replacing the assemblies of one or more events / or an event 
set, the icon is not updated, and the tooltip still shows the old model.
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ADMS-112860 Errors while generating a leaf spring with the given ltf file

ADMS-112847 Adams Car help not completely updated to flex bodies as I/J Parts

ADMS-112722

Environment variables changed in a Car session (e.g. in the Custom Environment 
table in the preferences dialog) without being saved to the config file, were 
ineffective for external solver analyses (analysis_mode = interactive or 
background), because the

ADMS-112692
In Template Builder, if you open the Modify Flexible Body dialog box and try to 
modify a part that was previously a general part (i.e. ge[lrs]_*_flex), Adams Car 
produces warning messages.

ADMS-112666 Preferences dialog help does not cover "Reset" and "Save" buttons

ADMS-112638
Adams Car session crashes while opening subsystem file with whitespace 
character before variant name.

ADMS-112619
When modifying an object in the Template Builder that is oriented relative to another 
construction frame, the angles shown on the dialog differ slightly from the existing 
orientation expression.

ADMS-112552 Wrong definition of camber angle mentioned in generated SVC report

ADMS-112296

The Driving Machine Testrig Request utility (under Setup) produced errors and 
wrongly displayed the requests of the active (non-driving-machine) testrig if the 
driving-machine testrig was an inactive child of the assembly. This has now been 
corrected.

ADMS-112225
An adjustable force, set up to control ride height, and saved in an ASCII template, 
may show the desired value in angle units rather than length units.

ADMS-111324
Some menu references in the documentation (e.g. about how to access Database 
Management) are outdated, i.e. do not reflect the new menu organization. This will 
be corrected in a future release soon.

ADMS-111180 Update help documentation for Overall Steer Ratio output

ADMS-110310
In the Isolator Parameter Identification dialog, the "Start Optimization" button 
reactivates after switching tabs, even though optimization is still in progress.

ADMS-110063 Car Getting Started guides need to be updated to new menu layout

ADMS-109295 Updated CDB_SEARCH_FILE function descriptions in online help

ADMS-104970 Information provided in online help where comments on analyses can be found

ADMS-90443
Incorrect behavior when an ARB is regenerated if a switch part refers to one of its 
component parts.

ADMS-79925

The following commands now properly support the previously introduced file back-
up paradigm:

* acar files assembly info

* acar files subsystem info

* acar assembly communicator export
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ADMS-79923

The following commands now properly support the previously introduced file back-
up paradigm:

* acar toolkit info

* acar toolkit files copy/rename

* list_info

ADMS-76119

Using the same road (3d_road_smooth_oval.xml) in different formats (OpenCRG 
and 3D Spline) the speed profile computed by SmartDriver is too low for the 
OpenCRG road. This has been resolved by correcting the bank angle passed to 
SmartDriver for OpenCRG roa

ADMS-69955 SVC Track Width definition updated in Adams online help

ADMS-69599
If a Parameter Variable has an associated macro, the macro will not be executed if 
the PV is modified in the Template Builder - only in Standard Interface.

ADMS-69598
If you create a parameter variable in your template and connect it to a macro, but do 
not create a "choices" variable through the Design Option utility, then the macro will 
not be executed automatically when the subsystem is opened.

ADMS-57138
Enhance routine to output additional output such as longitudinal velocity, lateral 
acceleration, yaw rate based on type as input in the var911.

ADMS-16820
Name of the Filter is also added to Group if user creates a Group by using 'Add to 
Group' option (Template Builder Mode)
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Known Issues

ADMS-114799
XML saved in Tire Testrig with numbers entered in dialog boxes end up with trailing 
numerals

ADMS-114742
Suspension analysis simulation failed when executed for 'External files' event with 
two lcf with different coordinate system modes

ADMS-113473 Issue with prefix added to the marker created on the mount part

ADMS-86548
Repeated and rapid modification of Communicator in Template Builder can lead to 
unresponsive Communicator dialog box

ADMS-85240

The suspension level compliance event does not use or populate a loadcase spline. 
Instead, point force actuators are created to apply loads on the wheel (e.g. pfl_
inboard_lateral_force_cp). 

The til_wheel force request has zero lateral and longitudinal force, however vertical 
(normal) force returns correct force values. The point force actuator's request gives 
correct force for lateral & longitudinal direction and can be used as a workaround for 
lateral and longitudinal force output.

ADMS-72303
Under some conditions, Adams Car is reporting incorrect wheel/spring, wheel/shock 
ratio and wheel rate for suspension and full vehicle SVC analyses.

ADMS-71370
Defining a large Initial Steer angle (e.g. 5 radians) as defined under Static Set-up in 
the Event, the static solution should return with a 5 radians initial steer angle applied 
to the steering wheel but returns with an incorrect steer angle instead.

ADMS-63369

When opening a template containing an Fe_Part, an Fe_Part is created based on 
the configuration saved in the template file.  Whereas, when a Subsystem is opened 
then it is updated based on subsystem parameters. This updating may cause 
unnecessary updates

ADMS-63229

The capacity factor data, using the torque converter example file (mdi_0001.tcf), 
does not allow the torque converter to develop enough torque to keep the engine 
spinning with the transmission when the vehicle is descending the hill with the 
throttle off.

ADMS-59022

When using a powertrain subsystem based on the _engine_transmission template 
from the acar_concept database, a static set-up of type 'settle' may converge to a 
wrong equilibrium, and apply a huge driving torque to the driveline. A 'straight' set-
up (if po

ADMS-50937

The caster output of the dynamic suspension analysis produce slightly different 
results when compared with static analysis. This could be happening due to slight 
difference in the compliance matrix computation as constraints are different betwee 
two analy

ADMS-42918
The exported request file from Adams Car doesn't have IDs and names in it for few 
components.

ADMS-39939 Parasolid file path not retained in the template file after saving the template as ASCII
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Adams Controls

FMU Encryption for Flex Bodies 28

Issues Resolved 29

Known Issues 29

FMU Encryption for Flex Bodies

Functional Mockup Units (FMUs) exported from Adams Controls now allow for encryption of flexible bodies. 
In past versions the Adams model and associated files could be encrypted, but the MNF flexible bodies 
could not be encrypted.  In this version of Adams, the .mtx files representing the flexible body information 
will be encrypted within the FMU. When encryption is active, the MNF file is not included in the FMU file as 
the encrypted mtx files contain the needed information.
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Issues Resolved

ADMS-112717 FMU export does not work when using ATV with Adams VIEW

ADMS-112610 FMU Passes FMU Checker Test externally but fails the test inside Adams View

ADMS-112185
Variables with comments in Car FMU plant export can create issues in 
modelDescription.xml

ADMS-86473
Added checks for the type of integrators set in the model. Enhanced parallelism is 
available only for real time simulations using fixed step integrators.

Known Issues

 

ADMS-115703 Assembly binary file model_name.asy added to unparameterized FMU

What’s New   



- 30 -

Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation 30

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI

Marc 2014.1 No support for ACSI

Marc 2014.2*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2015*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”
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Adams Driveline

Known Issues 31

Known Issues

ADMS-108774
During a bench test analysis in Adams Driveline, we observed incorrect engine RPM 
behavior when the brakes are engaged while the vehicle remains at a stand-still.
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Adams Durability

Issues Resolved 32

Issues Resolved

ADMS-113344
FEMDATA output does not work as expected when multiple subsystems are created 
from same template which contains (one or more) flexible bodies in Adams Car

ADMS-112942 Adams crashes when .mat file output is not writeable

ADMS-112295
Femdata output (load and modal files) is not working as expected for multiple 
flexible bodies
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Adams Explore

Issues Resolved 33

Issues Resolved

ADMS-95167
In Adams Explore the domain retrieved for the default computer name is the user 
domain instead of the computer domain.
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Adams Flex

Global and Modal Stiffness and Mass Scaling of Flexible Bodies 34

MNF Generation Default Yields Faster Animations 34

Issues Resolved 35

Known Issues 35

Global and Modal Stiffness and Mass Scaling of Flexible Bodies

Adams flexible bodies now permit users to alter their natural frequencies via simple scaling factors.  In 
previous releases one would have to have re-generated the modal neutral file (MNF) with different 
conditions.  A scaling factor applied to all modes’ stiffness and a scaling factor applied to all modes’ mass 
are now available.  Also, scaling of individual modes’ stiffnesses is now supported.

These factors are set in fields in the Modal ICs table accessible for the Flexible Body Modify dialog where 
they can be parameterized with design variables in addition to simply entering values.  Refreshing the table 
will display the altered natural frequencies.  Altered natural frequencies are also displayed in the Adams 
Solver message file (.msg).  Adams View command language and Adams Python scripting language 
support these new features too.  Adams Car users can access this functionality in the same ways and also 
can set these factors in Adams Car subsystem files.

MNF Generation Default Yields Faster Animations

Animations containing flexible bodies load faster when the MNF files have been produced using the  ‘MNF 
Optimizer’ found in the Adams Flex toolkit and the ‘Platform Specific’ Formatting option. In past versions of 
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Adams, the Flex toolkit would use ‘Standard Portable’ as the default for Formatting. This option has been 
removed from the Flex toolkit dialog box (it is still available on the command line of the Flex toolkit, if 
needed) and MNF files are now optimized using the setting ‘Platform Specific’, which loads faster in 
animations and works on all platforms.

MNF files generated by MSC Nastran, starting in 2024.2 Beta, will use, by default, this same “platform 
specific” setting.

 

Issues Resolved

ADMS-107922
Adams ViewFlex fails to create an MNF on poorly configured Internet Protocol (IP) 
addresses.

ADMS-85129 ViewFlex feature does not work without any internet connection in Adams View

Known Issues

ADMS-100735 Model import or open not functioning as expected with FE Part.

ADMS-97103
Saving flexible body inertia modeling as “rigid” at the subsystem level can result in 
error messages when opening the files in Adams version 2022.3 and beyond.

ADMS-87450 Simulations with rotating FE-part results in peaks, numerical singularities.
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Adams Insight

Issues Resolved 36

Known Issues 36

Issues Resolved

ADMS-114173
Factor values defined in workspace (xml experiment file) get rounded to one digit 
when writing out multi event regulator "mer" file and subsequent *.adm files

ADMS-109972
Adams Insight Factor negative nominal value's 'Low/upper limit' and 'Range' values 
are displayed as N/A when 'Delta Type' is set as "Relative Percent".

ADMS-107388 Insight fitting fails with missing results when "Exclude" runs option is selected

Known Issues

ADMS-106678
DOE of model with Parasolid geometry may stop without error when the number of 
trial runs exceeds 1000.
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Adams Machinery

Gear AT Spline Joint – Microgeometry & Imported Measurements 37

Romax to Adams Support for Cutout Gear Blanks 38

Romax Non-Linear Stiffness Connection Now Maps to General Bushing 38

Issues Resolved 39

Known Issues 39

Gear AT Spline Joint – Microgeometry & Imported Measurements

For spline joints in Gear AT it is now possible to import measured profiles and microgeometry. This allows 
for very high-fidelity models of spline joints:

Visualization tools provide rich previews:
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Romax to Adams Support for Cutout Gear Blanks

In previous releases, cylindrical gears (spur and helical) modeled via Adams Machinery only supported a 
pure cylindrical disk geometry for the gear blank.  With this release of Adams, such gears’ blanks can be 
modeled with so-called bosses and cutouts.  As such, the import of Romax models with such geometry 
features in the blanks is now better supported with these features being represented in the resulting Adams 
model.

 

Romax Non-Linear Stiffness Connection Now Maps to General Bushing

In previous releases, the Romax six degree-of-freedom non-linear stiffness component was mapped to an 
Adams FIELD object upon import of a Romax model into Adams View.  With this release of Adams, it is now 
mapped to the general bushing object.  The general bushing is easier to work with and more closely aligns 
with the usage intent of the Romax non-linear stiffness component compared to the FIELD object.
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Issues Resolved

 

ADMS-113816
GearAT: Tooth number 1 was occasionally set to the wrong random deviation value, 
so the load distribution between teeth could be incorrect for full flex spline contact.

ADMS-113614
Full flex gear contact missed the wear calculation, hence the request were not set 
properly.

ADMS-112302 Each undo-begin block should be completed by undo-end block

Known Issues

ADMS-100003 Gear AT Leadscrew solver crash if Leadscrew nut is too wide

ADMS-91552
The planetary gear built up in template builder does not keep the information in 
subsystem level

ADMS-85137 Wrong curvature calculation used in Hertz pressure in Hypoid gears for Gear AT

ADMS-76078
Changing the Adams unit system after creation of a belt system can cause the 
simulation to fail under some conditions and can cause issues with wizard file (.wzd) 
import.

ADMS-73283
Tooth shape appears incorrect under some conditions for trapezoidal pulley and belt 
when using certain DIN ISO standards.

ADMS-72681
Under some conditions for some specific inputs, the trapezoidal belt's pulley exhibits 
unexpected geometry.

ADMS-71381
In Adams Car, when a part is defined as symmetric then a mirror image of the part is 
created w.r.t center of the car. The direction of rotation (CW-CCW) is defined w.r.t to 
axis of revolution. In mirror image, both axis of revolution is opposite in direct

ADMS-54852
Roller chain sprocket can be defined using geometry 'parameters'. Alternatively, it 
can be defined using 'outline' or 'ISO606' options. In case of 'outline' configuration, 
the force definition is incorrect, causing unreasonable time to balance the forces

ADMS-54600

The involute gear profile can be specified using module, number of teeth, and profile 
modification coefficient. In the case of advanced3D gear method the sun gear 
geometry is not created properly when defined with very few teeth (nine) and 
considerable ad

ADMS-53853
The brushless DC motor does not run correctly as per the maximum angular velocity 
specified

ADMS-47208
Brushless DC motor exceeds the maximum torque specified by the user while 
designing the motor. This might be due to incorrect analytical formulation of the 
motor

ADMS-47207 Documentation needs to be improved regarding the analytical formulation of the 
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motor. It should also provide details if torque ripple and stator force is considered in 
the calculation .

ADMS-40348
The shape of links of silent chain can be specified in terms of curve coordinates. 
However, with certain set of inputs the curve is not generated correctly. The problem 
could be with plotting of the curve

ADMS-40177
3D spatial cable wrapping: for distantly placed pulleys (in the range of tens of 
meters) and very small misalignments angles, the cable wrapping algorithm fails

ADMS-38792
When a tensioner is placed in wrapping order of pulleys, the belt should be wrapped 
around the tensioner and simulation should exhibit the tension caused by the 
tensioner pulley. This does not happen in the case of smooth belt configuration.

ADMS-38594
Machinery elements like gear, pulley, cam, etc. can be constrained with other parts 
in the model in the form of revolute, fixed joints, etc. However, if these elements are 
to be constained with flexible parts like flexible_body or fe_part then the attache

ADMS-31960 Unable to chage direction of motor in runtime with curve based method for motor.

ADMS-30608

If users run the motor with the exact rated condition of voltage and fluency and the 
external load (load on motor) is within the motor torque limit, then the AC motor is 
showing abnormal behavior since current is remaining constant but torque is 
changing

ADMS-22387
A broken translational joint on the tensioner in a belt systems is observed when 
reading bin file created on 2013.1 in later versions.  Use .cmd as workaround
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Mechatronics

New Step and Filter Options for Signals 41

New Step and Filter Options for Signals

Mechatronics Signals (Actuators, Transducers, Inputs & Outputs) have two new options:

Step – to turn the signal on/off at any point in time,

Filter – to apply a simple Butterworth filter (ie: a lowpass filter) to a signal.

The Filter option lets the user create a low pass, high pass, band pass or band stop filter on the 
Mechatronics Signal. The Check Format and Display Plot button lets the user check the behavior of the 
filter in the frequency domain:
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Adams PostProcessor

Print to PDF 42

Issues Resolved 42

Known Issues 42

Print to PDF

Adams PostProcessor can now print pages directly to the PDF file format:

Issues Resolved

ADMS-114641 Can't switch back/forth between Adams View/PPT session without error messages

ADMS-114158 Updated new sim companion URL

Known Issues

ADMS-113660 Deformation legend not available for FE-part

ADMS-112747
Export to table option does not properly export data when multiple results are being 
exported

ADMS-106662 Clearance study overwritten with successive computations

ADMS-104580 Plotting multiple vibration analysis frequency responses at once
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ADMS-102513 Light setting not retained with saved database model.

ADMS-97124
AVI file exported through PostProcessor not viewable with Windows Media Player. 
Workaround is to use other video players (ex: VLC Media Player).

ADMS-92766
Car- Using the "File > Import" menu, tire force graphics are not displayed in 
PostProcessor

ADMS-91799 flex body plot deformation scale not matching plot values

ADMS-90601 Request (.req) file exported from Postprocessor has incomplete data

ADMS-88182
Adams PPT performance plotting issue (taking more time for operation) in Adams 
car 2022.2 compared with 2017.2

ADMS-87455 HTML file output from PostProcessor is not displaying in browser.

ADMS-81584
Under some conditions, values displayed in force graphic animation do not match 
the values for the same object as plotted in an XY plot.

ADMS-81355
Under some conditions, there is no X expression for the gain in the phase curve of a 
Bode plot in Adams PostProcessor

ADMS-73207
Under some conditions, model display is misaligned in Adams PostProcessor 
animation when the model is saved as an Adams View database (.bin) file.

ADMS-72385
Plot page background turning black and sluggishness in plotting the curve (with 
large data points) is observed while using the Linux machine remotely through 
remote access tool such as DCV NICE from Windows machine.

ADMS-69667
the "force" component of bumpstops request is not provided in the same 
location in the Adams postprocessor dashboard.

ADMS-61940
The user runs any standard simulation on a full vehicle truck model, the powertrain 
subsystem stays behind and the rest of the vehicle is moving in forward direction in 
animation. However, this issue is not observed if the user switches to a binary result

ADMS-61808
Adams fails to show units(NO UNITS) for unitless curve on postprocessor plot when 
plotting unit less entity and unit entity on same axis.

ADMS-60600
Adams fails to print top boarder line of postprocessor plot, on printing the 
postprocessor results in a pdf format.

ADMS-58625
Multiple cross plotting curves in Adams postprocessor can lead to missing plot 
curves. On clicking the refresh button or plot/page resizing, all curves appear 
correctly.

ADMS-54854
The result file storage differs based on the "type" of request definition. This is 
confusing when plotting quantities from a results file.

ADMS-54340
Runtime clearance study results in incorrect clearance values for revolution 
geometry

ADMS-51786
In the Adams postprocessor for the FFT-3D plot, there is a mismatch/difference 
between the color of the contour plot and the legend.

ADMS-40443 Adams Postprocessor on plotting Aligning Torque - Steer and Camber Compliance 
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curves shows incorrect units. Instead of showing deg-sec**2/kg-m**2, it shows deg-
sec**2/kg.

ADMS-40080 Problem choosing curves when Legend and curve overlap on a plot

ADMS-39459
Contact graphics is not displayed when animation is run after importing results of 
external solver

ADMS-23790
View-Reset GUI Dimensions only resets the graphics window (plot/animation) size 
but not the others (treeview and dashboard)

ADMS-21716
Adams Car bushing geometry disappears during animation when animating a 
second time after first  running the animation successfully and then clicking the reset 
button

ADMS-5552
No warning that velocity plots of CM in object measures when displacements are 
disabled in .res are actually Part Xform results
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Adams Real Time

Issues Resolved 45

Adams Real Time now supports the forthcoming version of CDTire/Realtime. This forthcoming version of 
CDTire is expected to be released early in the year 2025.

Issues Resolved

ADMS-105338
With MSC_ADAMS_TIRE_AFFINITY set, and after running a real time simulation 
for a longer time using a vehicle model equipped with STI based tires, oscillations 
occur and eventually the simulation fails. This has been resolved.

ADMS-69601
An FMU with open loop force based steering fails whereas the offline simulation 
runs fine using a customized event. Using rotation based steering works fine though 
for both FMU and offline simulations for this customized event.
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Adams SmartDriver

Known Issues 46

Known Issues

ADMS-103654
SENSOR "testrig.event_monitor_sensor" triggers unmotivated immediately at mini 
maneuver start
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Adams Solver

New RAMP Function 47

Issues Resolved 47

Known Issues 48

New RAMP Function

A RAMP function is now available in Adams Solver function expressions:
RAMP (x, x0, h0, m, rp)

Arguments

x Solver expression for independent value (ex: TIME)

x0 The corner point at which the RAMP function begins.

h0 The value before the RAMP  

m The slope of the RAMP

rp Rounding parameter

Issues Resolved

ADMS-115653
Updated Documentation for C++ Solver subroutines related to IFLAG=1 or 3 
handling

ADMS-113975 Statics has trouble converging when there is Contact geometry on massless parts.

ADMS-113787
SAVE/RELOAD may fail on models that use SAVE/STATES and contain FRICTION 
elements.

ADMS-113588 Added a check for the number of threads before starting the enhanced parallelism 
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algorithm. Enhanced parallelism is not possible if the number of threads is one.

ADMS-113407
Adams Solver does not recognize change in Contact "Max Stiction Deform" 
parameter.  Solver always uses the default value of 0.01.

ADMS-112151
The minimum distance point in Clearance between two boxes was randomly 
jumping between points with equal clearance when box edges were parallel.

ADMS-110388
New EP starting algorithm takes into account the possibility of an Euler singularity 
during the very first step.

ADMS-107707
LINEAR/EIGENSOL - ORIGINAL argument changed the damping option to use 
damping ratio in Eigen frequencies calculation

ADMS-68778
The Solver command OUTPUT/SEPARATOR is not working as expected. Although 
SEPARATOR is the default, .gra and .req files do not include the separator. Writing 
.gra and .req files always behaves as if NOSEPARATOR is specified.

ADMS-42391 function evals and steps number are incorrect

ADMS-12290
Initializing string when calling utility function GTSTRG from a C/C++ user subroutine 
is required but instructions are missing from online documentation on how to do this.

Known Issues

ADMS-109152
Differences in results between analyses run with binary file and the exported cmd 
file.

ADMS-104772 Missing angle unit conversion when exporting .adm file

ADMS-100365

Inaccurate reporting of CPU Time in the Solver msg file at the end of the simulation 
on Windows11 22H2 systems. This issue is a regression that was introduced 
starting in Windows 11 22H2. No workaround or solution exists from Microsoft.  
Reporting of Elapsed Times are not affected.

ADMS-97136 Cannot run the analysis by double clicking on the acf file.

ADMS-82810
The disabled element is recognized by the solver as enabled for the Contacts that 
refer to poly-lines

ADMS-75552
If switching to write the results file in ASCII or binary format all the requests that 
were present when using the default XML format are missing

ADMS-42738
If a marker (triad) is created on a curve to mark a specific location on curve, it is 
expected to retain the position while the curve-part is moving. However, the marker 
does not retain its position on a curve.

ADMS-16221
OUTPUT variables referencing deactivated BUSHING forces cause analysis failure.  
Workaround is to comment out or otherwise deactivate the OUTPUT variables.
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Adams Tire

Issues Resolved 49

Known Issues 49

Issues Resolved

ADMS-113748
Running a second simulation with FTire (and possibly other tire models) in Adams 
View fails using the internal Adams Solver. As a result performing a Design Study 
with the internal Solver may crash Adams View. This has been resolved.

Known Issues

ADMS-114794
Custom RDF (rounded triangle) used for the bottoming test in Tire Testrig does not 
affect results (same as flat road)

ADMS-114152 Problem generating the Flexible rim from the Tetra mesh FE model

ADMS-112621 Suspicious rear tire sinkage for multi-pass on soft soil

ADMS-107729
FTire - remote option won't work when done through UI, in batch mode this works 
but have to configure passwordless ssh to work seamlessly.

ADMS-107721
Adams and VTD co-simulation - strange/wrong results when driving over a road with 
a slope
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Adams Vibration

Issues Resolved 50

Known Issues 50

Issues Resolved

ADMS-105501 Simulation Script Name field in Perform Vibration Analysis dialog box disappears

ADMS-114786
'Vibration Animation' tab is not displayed when loaded Ride Vibration Animation for 
'Displacement' as 'Actuation type' in PPT

Known Issues

ADMS-109965 Actuator Plot for PSD based Input Channel is in incorrect due to unit inconsistency

ADMS-105504 Adams Car with Vibration - Input Channel Part not allowing flex selection
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Adams View

CAD Interoperability Version Support 51

Aggregate Mass Improvements 52

Function Builder – Bracket Highlights 53

Function Builder – Built-in Search Field 54

Issues Resolved 54

Known Issues 56

CAD Interoperability Version Support
The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2024.2 .

Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R33 Not Supported

CATIA V6 (.3dxml) 2014X → 2022X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 9 Not Supported

Inventor (.ipt, .iam) All → 2023 Not Supported

Solidworks (.sldprt, .sldasm) 99 → 2023 Not Supported

Unigraphics (.prt) 11.1 → NX CR 1953, 1957 and 
1969, 2212

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Aggregate Mass Improvements

The Aggregate Mass tool in Adams View (and Adams Car) has been enhanced to provide additional tensor 
output when a Relative To marker is specified. In addition, it is now possible to create a marker at the 
computed aggregate CM location.

When specifying a Relative To marker, the following additional inertia tensor information is reported:

What’s New   



- 53 -

When specifying the Create Marker at Aggregate CM choice and picking a part, a marker is automatically 
created at the aggregate cm location, having the principal axes aligned with the aggregate inertia:

Function Builder – Bracket Highlights

Detecting matching bracket pairs in function expressions is easier now with dynamic bracket highlighting, 
shown in Function Builder:

Highlights are shown for the following three types of closing brackets:
- (..expression..)
- [..expression..]
- {..expression..}
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Function Builder – Built-in Search Field

Locating functions is now easier thanks to the new search field in Function Builder. The list of functions is 
now filtered by both the Search field and the Category drown-down selection. Type in a search string, then 
change the Category from the default of All Functions to something else to locate the function that you 
need.

Issues Resolved

ADMS-114920
After opening F1 help for any dialog box then the second or later dialog box F1 help 
does not open on the Linux machine

ADMS-114663 Japanese GUI does not show Appearance Dialog after selecting multiple entities

ADMS-114298 undo/redo after suppress on parametric body.

ADMS-114249
Adams View session is crashing when we do Design study followed by Optimization 
and vise versa

ADMS-113730 Help link to SimCompanion Updated with new URL

ADMS-113572 Adams simulation don't initiate when the animation is loaded in postprocessor

ADMS-113394 Request dialog has inconsistent setting for Title option

ADMS-113166
Can export aggregate mass from model browser in a Japanese environment when 
selects multiple parts

ADMS-112701 Updated Japanese translation for "Create a Advanced Bushing"

ADMS-111177 Warnings when creating a createPt2pt measure using Adams Python

ADMS-111175 The design variables are created with incorrect range i.e. units using Adams Python
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ADMS-109998 Issue in retrieving Model Base Name

ADMS-109884 The force output for the constraint is correct position and correct sign.

ADMS-109149
Wavefront (obj) export from Adams Car exports files for parts with no active 
gometries

ADMS-107627

When a part consists of multiple Parasolid geometry, if user defined density is 
specified by user, Adams View 2023.4.1 gives the following error, "WARNING: 
Overwriting density of 1000000000000.000000 for the parent part .MODEL_
1.PART_2 to value in importeimported file, 7750.332824."

ADMS-71391 When 4K monitor is used, Adams may not scale correctly with font size changes

ADMS-61425
Temporary settings files (.tsf) cannot be used to switch objects' properties between 
Adams Solver function based definitions and Adams Solver user subroutine based 
definitions.  Any such switches fail to revert after the .tsf is applied.

ADMS-57041

View management commands are not working. User may experience trouble while 
restoring view using command

view management restore saved_view_name=
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Known Issues

ADMS-114594 Model in Adams view containing GearAT and BearingAT elements crashed

ADMS-114260 Adams python interpreter waits for more input and cannot be stopped

ADMS-113603
Wrong mass moment of inertia calculated for discrete flexible link, using "properties" 
cross section input

ADMS-113280
Adams Car template builder doesn’t allow to close the template after modifying the 
flexible body connections

ADMS-113172
Parametrization defined with rigid body do not retain when it is converted to flexible 
body by ViewFlex.

ADMS-110745 Part Extrusion loses Parametrization if the Part's global location is changed

ADMS-110505 Command Server not working on Linux

ADMS-109148
When exporting obj files Adams overwrites geometries that have the same part 
name in different subsystems

ADMS-108550
When modifying the translational point motion to rotational point motion, or vice-
versa, errors occur for initial conditions

ADMS-106688
when spline_read subroutine is used with external solver, simulation fails. AMD 
needs to allow BLOCK and ROUTINE arguments to coexist in Solver SPLINE 
statement.

ADMS-106260
Certain 'ANGLES' are used to get Direction Cosine Matrix generated by TMAT. 
When these Direction coises are used as input for ANGLES() function, it does not 
return same Euler angles which were used as input

ADMS-106129 Running Four-Post Vibration analysis twice results in a "conflicting IDs" error.

ADMS-104464 FE_PART section based on zy_points generic does not seem to be supported

ADMS-103576 Motion measure characteristic changes to torque unexpectedly.

ADMS-103474
Shell Geometry does not look good for some complex shapes when generating FE 
Parts using XYZ coordinates

ADMS-103051 Attached Creo 7 geometry file shows holes on surfaces.

ADMS-99994
Incorrect motion information in the log file when run analysis using *.acf file having 
the DEACTIVATE/MOTION command after SAVE/RELOAD.

ADMS-99003 Corrupted graphics when positioning of FE Part with preload

ADMS-98341 Failure when loading python module matlab.engine in Adams View

ADMS-96894 Cable wrapping for system with many pulleys can fail

ADMS-95010
Model browser does not update after creating new state variable. User needs to 
close and reopen the Elements folder to see the update.

ADMS-94886 If session unit is set to 'mm' and design variable referenced for X values of spline, 
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spline gets created with X values multiplied by 1000

Workaround: do not use design variable in this case.

ADMS-92342
A design variable with the AGGREGATE_MASS() function in it, along with 
referenced parts having user-defined masses does not properly update when the 
CM location of one of the parts is altered.

ADMS-91964
There is an orientation issue with extruded geometry when created by following the 
bspline curve

ADMS-90610 Adams View memory usage growing while creating many files in batch

ADMS-84401
For a specific binary file, when the scripted simulation is ran with “write Files only” 
option, the Parasolid file is not getting generated. External simulations then fail as 
the Parasolid file is not found.

ADMS-81674
The I and J markers of bushings connecting two FE Parts with hollow cross-sections 
will get shifted in location if the model is exported as an Adams View command file 
(.cmd).

ADMS-76384
Under some conditions FE Parts will improperly reference the underlying graphical 
curve causing errors upon .cmd import and sometimes causing the Adams View 
session to become unresponsive.

ADMS-75791
When a State Variable is renamed or altered, the Model Browser scrolls back to the 
top.

ADMS-75145
SHL file generated by Adams with MMKS units does not import properly into an FE 
Part as an external geometry

ADMS-75038
Under some conditions the flat part of obstacles in road geometry doe not shade 
properly.  Try precision shading to improve, but not solve, the issue.

ADMS-74664
There could be limitation in loading result files that are larger than 60GB, with 
contact incidences, in Adams View

ADMS-71387
Slightly different simulation results (less than 1% difference in some outputs) may 
result when comparing simulation results run inside a View interactive session with 
results run in a View batch session.

ADMS-64810
The new object creation like state variable does not update in Model Tree in 
Adams/car automatically, manually refresh is required

ADMS-60930
The time it takes for Adams View to delete results from the Model Browser can be 
very long when the result size is large

ADMS-54234
The "marker modify" command does not work in the correct reference frame if the 
values supplied for 'location' are enclosed in parentheses

ADMS-53889 Structure of the Analysis object is different with internal & external solver.

ADMS-53880

When opening an ASCII tire template with external CAD geometry, an error 
message is issued and the geometry is imported incorrectly.  Users may 
workaround this issue in two ways:

1. Specify the CAD geometry directly in the tire property file. See mdids://
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ADMS-53516
In Adams Car if a joint Force is created and is modified with Display Attribute (e.g 
color/style/size of the line), the modifications in the display attribute will not retain 
during the animation, or after the animation is played.

ADMS-51334
Adams Online Help cannot be shown for some auto-generated Command Navigator 
dialog boxes

ADMS-50894
Exporting a .shl geometry file and then importing back into Adams can result in 
geometry differences for finely tuned rendering parameters on export/import.

ADMS-50747
Variable reference function "user_string" does not handle unit conversion properly in 
case of "mmks"

ADMS-48293

"Remove Parametric Expressions" option not working properly, incorrectly deletes 
parent object. This occurs when a force element, for example, references a state 
VARIABLE using a VARVAL() function; deleting the VARIABLE will incorrectly also 
delete the referencing object (the force element, in this example) even though 
"Remove Parametric Expressions" is chosen.

ADMS-47673 Table editor->Motions Table Editor Filter doesn't show "General Motion" option .

ADMS-46136 Adams fails to to translate hollow geometry(Box) having chamfer on its edge.

ADMS-45908
Some tables in Adams View dialogs do not properly display spring damper 
properties when using the UDE-based spring damper.

ADMS-45471 Some entity classes in adamspy do not support all properties for that entity

ADMS-45350
Incorrect results observed for flex analysis, when saving and opening the bin file 
multiple times.

ADMS-45099
For some of the imported IGES geometries of curves of degree 5, the shape may not 
match with the shape of source of the curve.

ADMS-44883
On importing bigger external pararsolid geometries(non-Adams) assembly models, 
Adams may fail to import some geometries.

ADMS-42441
The ORI_GLOBAL() function in Adams does not work correctly for angles beyond 
90 degrees

ADMS-41432
The calculated volume of a cylinder in Adams View is affected in an unexpected way 
while changing the cylinder side count (especially around the value of 20)

ADMS-40912
Adams datatable widget's performance is affected by number of rows and columns. 
User will experience slow datatable performance, If dealing with the huge(quite 
large number of rows and columns) tabular data in data table.

ADMS-40354
Range Measures cannot be referenced by other Measures using runtime 
expressions. Range measures only update at the end of a simulation.

ADMS-39355
If a User Defined Element (UDE) definition lies in some library. User can create an 
instance from this definition in a model. However, if this model is saved as binary of 
command file then only the contents of the model are written in the file (and not th

ADMS-34194
On Windows 10 virtual machines when VMware tools are installed to make a full 
screen virtual machine, then some of the Adams-View-based product sessions 
might terminate unexpectedly (Adams View, Adams Car, Adams Driveline). 
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Uninstalling the Vmware tools alleviates the issue.

ADMS-32067 Bearing disappears when selecting "reset to start" in animation control dialog.

ADMS-31937
When copying a cam system its follower motion will not be copied.  Both cam 
systems will reference the same follower motion object.

ADMS-23976

On machines with multiple graphics hardware options, use of the "CPU integrated" 
graphics hardware (for example, "Intel HD Graphics") may cause problems with 
display of flexible bodies and FE parts in wireframe mode.  The workaround is to use 
the other gr

ADMS-22004
Zero volume of cylinders with 1 or 2 segments, with angle extension less than 360 
degrees

ADMS-21941
Torsional springs missing when merge two models (each containing one) via "Model 
assemble" command.  Workaround is to use a rotational sforce instead.

ADMS-20196 Force Display ON/OFF option is not working for the FE Load

ADMS-19599
Menu operations from Adams View for view manipulation (front, fit, zoom, etc) act 
upon the PostProcessor window if it is also open

ADMS-16288
Some options on the View Management Orient command not working correctly. 
Workaround is to rotate the View via the tools available in the graphics window and 
toolbar.

ADMS-12740
Error in Mass property calculated for copied part with the original part being a 
parasolid for some (not all) externally imported parasolid files

ADMS-5419 Want a documented search-order for locations when loading plugins
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Adams Car

Communicator Map

A graphical representation of Communicator connections between subsystems is now available: 

Featuring simple filtering controls, the Communicator Map draws communicator relationships in an easy to 
follow, graphical format. Subsystem blocks and connection lines show different levels of detail, all the way 
down to typical communicator connection output: 
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Edit in Template

Making changes to a template is much easier now with the new Edit in Template functionality that is found 
at the Assembly level of a vehicle model. This new automation functionality lets an expert user easily open 
a template in an Assembly from the Model Browser: 

 

This is also available by right-clicking elements in the model:

 

Selecting these actions will automatically locate the template file for a subsystem and load it into Template 
Builder for immediate modification. 
 

Further automation is introduced for the return path when a template has been changed. Adams Car will 
now automatically apply the template changes to a subsystem and then update the assembly with the 
modified subsystem. This greatly streamlines the process of changing a template and realizing the changes 
in an assembly:
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Show & Hide Subsystems

It is now easier to show/hide subsystems when inspecting a vehicle assembly. Right-clicking a subsystem 
in the Model Browser includes new menu picks for Show and/or Hide, as shown below:

 

 

Flexible Rim

It is now possible to incorporate a flexible rim model into Adams Car. This new functionality is available with 
tire models that use CDTire, from Fraunhofer ITWM 
(https://www.itwm.fraunhofer.de/en/departments/mf/cdtire.html). 

 

The interface for this new functionality is presented in the Flex Rim FE Preprocessing dialog box, as shown: 
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This takes care of the many steps needed to integrate a flexible body into a vehicle assembly. 

 

Note:   

F1 Context Help is not working for the Flex Rim Preprocessing dialog 
box. Open the Adams Help documentation from the Adams Help menu 
and search for ‘flex rim’ to locate the complete Help documentation. This 
is found in the Help section: Adams Car Package → Adams Tire → 
Contact Methods → Flex Rim. 

User-Defined Plot and Report Templates

Adams Car uses Plot Template Files (.plt, located in /plot_configs.tbl) and Report Template Files (.rtp, 
located in /report_templates.tbl) to create standard Plots and Reports for all of the simulation Events. It is 
now easier to customize these templates via the Post-Processing section of Adams Car Preferences 
(Settings → Preferences):
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The settings above specify the default template files to be used. To use a different template without setting 
it as the default, use the new context menu picks in the Event Browser, as shown below: 
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New options also exist in Adams PostProcessor for importing Plot/Report templates: 

 

Tension Leafspring (Without Shackle) 

The Leafspring Editor now supports creation of leafsprings with or without a shackle: 

 

The new Shackle Option parameter can be modified in the Editor shown above, or directly using a text 
editor on the .ltf property file.
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Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI

Marc 2014.1 No support for ACSI

Marc 2014.2*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2015*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”

Adams Durability

Rainflow – Fatigue Cycle Counting

The Rainflow counting method computes the magnitude and quantity of different loading cycles found in a 
complex stress-time history. The number of cycles at different mean values and the corresponding min/max 
ranges of the cycles can be used to estimate fatigue damage in a component. A typical load-time history 
from a durability analysis, for example, might appear like so: 
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Rainflow cycle counting seeks to describe this signal as a collection of loading cycles, each cycle having a 
mean and amplitude value, as shown below: 

 

Several plot types are available based on this information:

 1. Rainflow Histogram as a function of cycle amplitude and mean value,

 2. Rainflow Histogram as a function of cycle start and end values,

 3. Range Pairs - the number of cycles as a function of cycle amplitude,

 4. Cumulative Range Pairs - a cumulative form of the data above, 

 5. Level Crossings - range amplitudes as a function of the number of cycles,

 6. Equivalent Load & Damage - typically used if the time history represents stress in the material but if 
the relationship between loads and stress is understood then this may also be applied to load 
histories.
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This new functionality is found in Adams PostProcessor when the Durability plugin (Tools → Plugin 
Manager) is loaded: 

 

 

Notes:   

These plots are typically overlayed with 2 or more data sources. Currently it is 
only possible to plot a single result on a single plot. To overlay plots of Range 
Pairs and Level Crossings for multiple results, do the following: 

 1. Plot the Range Pairs / Level Crossings of interest for the first result set. 

 2. Create a second, similar, plot for the 2nd result set of interest. 

 3. Use Copy / Paste to overlay plots: select the first curve of interest and 
select Edit àCopy. 

 4. Navigate to the second plot page and use the menus: Edit àPaste to add 
the previously-selected curve to the new page. 

Acoustic Pressure Recovery in Flexible Bodies

Acoustic pressure recovery is now possible in Adams, using MNF files that have been generated in MSC 
Nastran 2024.1.

If a coupled fluid-structure interaction (FSI) is defined in the MSC Nastran model and one creates an MNF, 
there is an option to include acoustic modes from select fluid grids in the MNF. If this is done, the user can 
recover acoustic pressure time histories of Adams results using Durability without having to go back to 
MSC Nastran. This MNF information can be verified using the Adams Flex Toolkit, shown below.
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Adams Flex

Rotor Dynamics Effects in Flex Bodies

The Modal Neutral File (mnf) file format used for flexible bodies can now include rotor dynamics effects, as 
computed by a Finite Element package such as Nastran. A new simulation mode exists for running  
successive dynamic & linear analyses and a new charting option named Rotor Dynamics Campbell Plot is 
meant for these results. 

Specifically, Adams Flex now recognizes mnf files containing Rotor Dynamics effects, as shown below. 
These effects are included in the mnf file using MSC Nastran 2024.1 and SOL107:

 

Rotor Dynamics effects for flex bodies must be enabled (Settings  Solver → Flex Bodies…) as shown:

 

What’s New   



- 72 -

A new simulation sequence particular to rotor dynamics is included with the simulation controls: 

 

And the new plotting type for Rotor Dynamics is available in PostProcessor: 
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Adams Machinery

GearAT: Gear MicroGeometry Variations

It is now possible to create gears with micro variations in the geometry to simulate manufacturing 
roughness and similar imperfections:

 

Deviations in geometry are specified with respect to the nominal shape; users can specify different patterns 
for the deviations as shown: 
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The manufactured gear can be measured on each tooth and flank, the produced measurements can be 
applied to each tooth so real topology and deviations are used in simulations.
 

GearAT: Exact Gear Tooth Measurements

The manufactured gear can be measured on each tooth and flank and the produced measurements can be 
applied to each tooth. This real topology and deviations is used for very detailed simulations.
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Visualization tools are included to check the imported data: 
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Romax to Adams

A new Getting Started guide is available in the standard Help documentation for Romax-to-Adams. A step 
by step example shows the process of easily converting a Romax model into an equivalent Adams model.

 

REXS File Import 

It is now possible to import REXS model files into Adams if Romax (version 2023.1 or greater) is installed. 
The File Import dialog box can now accept this file format: 
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REXS models are converted, in the background using Romax, to the R2A (Romax to Adams) specification 
and then loaded in Adams. 

 

Adams Solver

Utility Subroutines for Contact Node Incidents

For users that create contact subroutines (CNFSUB, CFFSUB) for flexible bodies, new utility subroutines 
exist that are used to identify node incidents and detailed contact data. These are:

N_NODE_INCIDENTS(id, oneflag, index, errflag)

Input Arguments:
 
id - integer specifying CONTACT ID
oneflag - integer specifying whether or not CNNSUB/CFFSUB should
be called once or multiple times:
oneflag = 1 specifies CNFSUB to be called once
oneflag = 2 specifies CFFSUB to be called once
 
Output
index - integer specifying Contact incident, numbered 1 to N
errflag - an integer specifying success/failure of function call

FLEX_CONTACT_DATA(id, comp, data, errflag)

Input Arguments
 
id - integer specifying CONTACT ID
comp - integer specifying node incident data to be returned:
1. loci (available in both CNFSUB/CFFSUB)
2. locj (available in both CNFSUB/CFFSUB)
3. ni (available only in CNFSUB)
4. nj (available only in CNFSUB)
5. gap (available only in CNFSUB)
6. gapdot (available only in CNFSUB)
7. gapdotdot (available only in CNFSUB)
8. slip displacement (available only in CFFSUB)
9. slip velocity (available only in CFFSUB)
10. normal force at node (available only in CFFSUB)
 
Output Arguments

What’s New   



- 78 -

 
data - an double precision array of requested node incident data
errflag - an integer specifying success/failure of function call

 

New Handling of Angles – ADVANCED_ROTATION

Adams Solver has a new method for internally describing angles that is expected to have speed and 
robustness benefits for certain models. This new method avoids angular singularities during solution, 
preventing simulation restarts. However, in order to accomplish this, additional equations are added to the 
equation set so some robust models may run slightly slower. This is activated via the PREFERENCES 
Statement: 

PREFERENCES/ADVANCED_ROTATION = {ON, OFF}

Or within the Adams View interface under Advanced Rotation: 

 

Adams Tire

Runtime Inflation Pressure Changes (FTire) 

Simulating the effect of tire pressure changes on vehicle events is now possible when using the 
Cosin/FTire tire formulation. Tire pressure is specified using a runtime expression, as shown: 
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The effect of sudden tire pressure changes on a vehicle can easily be studied. The following example 
shows how the tire lateral force is greatly influenced by a drop in inflation pressure:

 

Adams View

Importing CAD with Density – New Defaults

Some CAD geometry types support a density specification. Prior versions would overwrite mass & density 
information for this operation. A new setting exists on the CAD import dialog box to avoid overwriting 
density information, as shown below. The default setting for this differs between Adams View and Adams 
Car as follows: 

● Adams View: Ignore CAD Density defaults to Off.
● Adams Car: Ignore CAD Density defaults to On.
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CAD Interoperability Version Support 

The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2024.2 . 
 

Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R33 Not Supported

CATIA V6 (.3dxml) 2014X → 2022X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 9 Not Supported

Inventor (.ipt, .iam) All → 2023 Not Supported
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Format Import Version Export Version

Solidworks (.sldprt, .sldasm) 99 → 2023 Not Supported

Unigraphics (.prt) 11.1 → NX CR 1953, 1957 and 
1969, 2212

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Adams Car

New Menu Structure

The menu structure has been updated to reflect a logical progression of tasks using the menus. To this end, 
a new Setup menu contains items that are done before the Simulate menu operations. Additionally, the 
menus make essential functions more easily discovered. The new ‘Setup’ menu now appears between 
Adjust and Simulate: 

With this approach the Adjust menu is mainly used to modify individual items and the Setup menu is mainly 
used to apply subsystem-wide or assembly-related changes, for example: 

Besides this, file operations (such as database (cdb) management) have been moved from the Tools menu 
into the File menu:
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The following table maps old menu locations to new locations: 

 

Old Menu Location New Menu Location

File -> Info -> Modified Files File -> Show -> Model Changes

File -> Info -> Subsystem Setup -> Model Info -> Subsystem Info

File -> Manage -> Subsystems -> Synchronize Setup -> Manage Subsystems -> Synchronize

File -> Info -> Assembly Setup -> Model Info -> Assembly Info

File -> Manage -> Assemblies -> Add Subsystem Setup -> Manage Assemblies -> Add Subsystem

File -> Manage -> Assemblies -> Add Testrig Setup -> Manage Assemblies -> Add Testrig

File -> Manage -> Assemblies -> Remove Subsystem Setup -> Manage Assemblies -> Remove Subsystem

File -> Manage -> Assemblies -> Remove Testrig Setup -> Manage Assemblies -> Remove Testrig

File -> Manage -> Assemblies -> Replace Subsystem Setup -> Manage Assemblies -> Replace Subsystem

File -> Manage -> Assemblies -> Replace Testrig Setup -> Manage Assemblies -> Replace Testrig

File -> Manage -> Assemblies -> Testrig Activity Setup -> Manage Assemblies -> Toggle Testrig 
Activity

File -> Manage -> Assemblies -> Toggle Subsystem 
Activity

Setup -> Manage Assemblies -> Toggle Subsystem 
Activity

File -> Manage -> Assemblies -> Update Variant Setup -> Manage Variants -> Update Assembly 
Variant

File -> Manage -> Subsystems -> Update Setup -> Manage Subsystems -> Update

File -> Manage -> Subsystems -> Update Setup -> Manage Subsystems -> Update

File -> Manage -> Assemblies -> Create Variant Setup -> Manage Variants -> Create Assembly 
Variant

File -> Manage -> Assemblies/Subsystems -> Delete 
Variant Setup -> Manage Variants -> Delete Variant

File -> Manage -> Assemblies/Subsystems -> Rename 
Variant Setup -> Manage Variants -> Rename Variant

Adjust -> Adjust Mass Setup -> Mass Properties -> Design Mass 
Adjustment

Adjust -> Loading -> Table Setup -> Mass Properties -> Loading Configuration

Adjust -> Shift Setup -> Manage Subsystems -> Shift
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Adjust -> Sprung Mass Table Setup -> Mass Properties -> Sprung Mass Table

Adjust -> Actuators ->Table Setup -> General Actuation -> Actuator Table

Adjust -> Kinematic Toggle Setup -> Model Simplification -> Kinematic Toggle

Simulate -> Full Vehicle -> Vehicle Setup -> Delete Road 
Geometry

Setup -> Vehicle Environment -> Delete Road 
Geometry

Simulate -> Full Vehicle -> Vehicle Setup -> Set Full 
Vehicle Parameters

Setup -> Full Vehicle Assembly -> Full Vehicle 
Parameters

Simulate -> General Actuation Analysis -> Actuation Input 
File -> Open

Setup -> General Actuation -> Actuation Input File -> 
Open

Simulate -> General Actuation Analysis -> Actuation Input 
File -> Open

Setup -> General Actuation -> Actuation Input File -> 
Save

Simulate -> Full-Vehicle Analysis -> Path Optimization Setup -> Vehicle Environment -> Path Optimization

Simulate -> Full-Vehicle Analysis -> Event Builder Setup -> Vehicle Environment -> Event Builder

Simulate -> Full-Vehicle Analysis -> Road Builder Setup -> Vehicle Environment -> Road Builder

Simulate -> Full-Vehicle Analysis -> Vehicle Set-Up -> Set 
Powertrain Parameters

Setup -> Full Vehicle Assembly -> Powertrain 
Parameters

Simulate -> Full-Vehicle Analysis -> Vehicle Set-Up -> Set 
SDI Request Activity Setup -> Output & Requests -> Driving Machine

Simulate -> Full-Vehicle Analysis -Road Conversion Setup -> Vehicle Environment -> Road Conversion

Simulate -> Full-Vehicle Analysis -> Set Road for 
Individual Tires

Setup -> Vehicle Environment -> Set Road for 
Individual Tires

Simulate -> Full-Vehicle Analysis -> Vehicle Set-Up -> 
Static Vehicle Set-Up

Setup -> Full Vehicle Assembly -> Static Vehicle Set-
Up

Simulate -> Suspension Analysis -> Create Static 
Loadcase

Setup -> Suspension Assembly -> Create Static 
Loadcase

Simulate -> Suspension Analysis -> Set Suspension 
Parameters

Setup -> Suspension Assembly -> Suspension 
Parameters

Review -> Analysis Management -> Run (acf) Simulate -> ACF Submit

Tools -> Database Management -> Add File -> Manage Databases -> Database Management 
-> Add

Tools -> Database Management -> Create File -> Manage Databases -> Database Management 
-> Create

Tools -> Database Management -> Database Migration Tools -> Database Conversion -> Database 
Migration

Tools -> Model Diagnostics -> Highlight Connectivity Setup -> Model Diagnostics -> Highlight Connectivity

Tools -> Model Diagnostics -> Model Auditor Setup -> Model Diagnostics -> Model Auditor

Tools -> Model Diagnostics -> Spline Check/Repair Setup -> Model Diagnostics -> Spline Check/Repair

Tools -> Model Diagnostics -> Spline Comparison Setup -> Model Diagnostics -> Spline Comparison

Tools -> Model Reduction -> Anti-Roll Bars Setup -> Model Simplification -> Anti-Roll Bars

Tools -> Model Reduction -> Remove Interface Parts Setup -> Model Simplification -> Remove Interface 
Parts

Tools -> Model Reduction -> Tires Setup -> Model Simplification -> Tires

Tools -> Requests -> Request Activity Setup -> Output & Requests -> Request Activity

Tools -> Requests -> Request Map Activity Setup -> Output & Requests -> Request Map Activity

Tools -> Requests -> Request Map Editor Setup -> Output & Requests -> Request Map Editor

Tools -> Database Management -> Database Version Tools -> Database Conversion -> Database Version 
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Upgrade Upgrade

Tools -> Database Management -> Publish Assembly File -> Publish -> Assembly

Tools -> Database Management -> Publish Subsystem File -> Publish -> Subsystem

Tools -> Database Management -> Remove from Session File -> Manage Databases -> Database Management 
-> Remove

Tools -> Database Management -> Set Default Writable File -> Manage Databases -> Database Management

Tools -> Model Diagnostics -> Entity Info Setup -> Model Info -> Entity Info

Tools -> Model Reduction -> Assembly Repositioning Setup -> Manage Assemblies -> Reposition

Tools -> Model Reduction -> Remove Switch Parts Setup -> Model Simplification -> Remove Switch 
Parts

n/a File -> Save -> Preferences

New API For Optimization & Multi-Run Applications

A new Application Programming Interface (API) for Adams Car has been created to simplify the process of 
simulating & evaluating Adams Car models. This API, written in Python, simplifies: 

● The inspection and simulation of existing Event or Event Set files, 
● Opening, creating, saving & modifying Subsystems and Assemblies, 
● The retrieval of Objective values and Result Set vectors and much more. 

Complete examples are found in the Adams Car installation folder under the \acar\examples\python_api\ 
folder. Documentation of the various classes & methods is found in Help, entitled ‘Adams Car API Help’. 

Here is an abbreviated example for how to run an Event found in an Event Set file and extract a key metric 
from the simulation results:
from msc.ADAMS.acar.event import EventSetManager
esm = EventSetManager()
esm.import_event_sets("example1.esf")
my_event = esm['default']['api_example1_01_sdi']
my_event.execute('interactive')
my_event.generate_report()
print(my_event.report_metrics.keys())
print(my_event.report_metric_value('rear_axle_load'))
 

Some of the objects that can be called from this Python API include: 

● Assembly, Subsystem, Testrig
● Database
● Event, Event Set, EventSetManager
● ExportFMU
● Utils

Improvements to Low-Speed Reverse Parking Events

Robustness improvements have been made to the Driving Machine that is used in machine-controlled 
parking events (closed loop steering events following a prescribed path), specifically for driving in reverse. 
This particularly applies to the case where uneven road profiles and realistic tires (that exhibit a delay in the 
build-up of lateral forces) would previously result in undesired steering response.  

The Connecting Contour parameter, found in the Event Builder for Trajectory Planning, has also been 
enhanced with an ‘auto’ option. This new ‘auto’ option can select between the (default) cubic method and 
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the circular method, depending on driving conditions. The circular method typically works best for reverse 
driving, low-speed events. 

If users select ‘auto’ for the Connecting Contour, the Driving Machine will use a “circular” connecting 
contour for reverse driving (when gear<0). This switches back to the default “cubic” connecting contour for 
forward driving if gear>0. This allows for using the same event settings for both forward and backwards 
driving.

In addition, assuming that the gyro is mounted at the location of the rear axle, the minimum preview 
distance (by default set to 5 meters) is reduced by the wheelbase if gear < 0. It should also be noted that a 
correction of the throttle/brake controller was made and now properly takes the gravitation force into 
account in the feedforward longitudinal controller while driving in reverse on a slope.

Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI

Marc 2014.1 No support for ACSI

Marc 2014.2*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2015*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”

Adams PostProcessor

New 2D Order Plots from 3D FFT Plots

New Order Analysis plots are available when working with 3D FFT Order Analysis Spectrum plots (the 
General 3D FFT plot is not supported). This new functionality allows a user to create a 2D Curve Slice from 
an existing 3D FFT plot, as shown below: 
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Order plots can be created for: 

● Amplitude vs RPM at Orders (example above), 
● Amplitude vs Order at an RPM (example below). 
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Adams Real Time

Separate Cores for Tires

Real Time simulations running on SIMulation Worbench (SimWB) can realize frame rate improvements by 
assigning specific computer cores to the tire models in the vehicle. 

By default, a tire model will run within the cores specified by MSC_ADAMS_THREAD_AFFINITY_SET0. 
Adams Solver will call the tire models and wait for the tire models to finish the force calculations.

For the tires that use the Standard Tire Interface (STI), thus the Adams Tire models and third-party tire 
models using the STI plugin, one can specify that the tire models should use separate cores for their force 
calculation by setting the environment variable MSC_ADAMS_TIRE_AFFINITY. In this way, the vehicle 
model frame rate will not suffer from all tire force calculations. For each tire a dedicated core needs to be 
specified and should not interfere with the cores specified by MSC_ADAMS_THREAD_AFFINITY_SET0. 
When having 4 tires, using 6 threads for the vehicle model, the specification could look like:
MDI_ADAMS_FORCE_NTHREAD=6
MSC_ADAMS_THREAD_AFFINITY_SET0=2-7
MSC_ADAMS_TIRE_AFFINITY=8,9,10,11
 

Real Time Animation on Linux Discontinued after 2023.4

The Real Time animation capability currently offered on Linux will be discontinued after the 2023.4 release. 
Hexagon is planning an improved real time animation capability for a future release.

Adams Solver

New Contact Measurement Functions

Additional information about CONTACT elements can now be accessed using the new runtime function:  
CONTACT_DATA(id, comp, flag)

This function provides, based on the ‘comp’ input setting, runtime measurement of the following CONTACT 
parameters: 

 1. Penetration Depth

 2. Penetration Velocity

 3. Penetration Boring Velocity

 4. Slip Deformation Magnitude

 5. Slip Velocity Magnitude (Speed) 

The ‘flag’ input setting determines if the Maximum (0) or Minimum (1) of all incidents for this CONTACT, at 
this time, is returned. 

Additionally, the CONTACT() runtime function has been expanded to include Normal Magnitude and 
Friction Magnitude. The complete list of outputs available with the CONTACT() runtime function is now: 

 1. Fm

 2. Fx

 3. Fy
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 4. Fz

 5. Tm

 6. Tx

 7. Ty

 8. Tz

 9. Normal Mag

 10. Friction Mag

For users creating CNFSUB() and CFFSUB() subroutines, new utility subroutines are available like so: 

● N_CONTACT_INCIDENTS() – return the number of contact incidents associated with this contact 
element for this iteration. 

● CONTACT_INCIDENT_INDEX() – return the current contact incident. Assumed to be called from a 
CNFSUB() or a CFFSUB() when the subroutine author needs to keep track of multiple contact 
incident locations for a single contact element.

Contact Performance Improvement

Performance improvements of up to 3X in wall time can be realized in simulations involving rigid body 
contact when using the HHT integrator. This speed-up will depend on model size, contact parameters and 
the number of Euler singularities that Solver encounters during the simulation.
 

Adams View

CAD Interoperability Version Support 

The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2023.4. 

 

Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R33 Not Supported

CATIA V6 (.3dxml) 2014X → 2022X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 9 Not Supported

Inventor (.ipt, .iam) All → 2023 Not Supported

Solidworks (.sldprt, .sldasm) 99 → 2023 Not Supported
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Format Import Version Export Version

Unigraphics (.prt) 11.1 → NX CR 1953, 1957 and 
1969, 2212

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Adams Car

Point Motion Actuators

Adams Car traditionally has supported Actuator types of joint force, joint motion, point force & point torque. 
With this release it is now possible to create an Actuator of type ‘point motion’: 

 

 

Background Simulation Shell Shows ACF Filename

Background simulations launched from Adams Car now show both the name and location of the currently-
running ACF file in the title-bar of the simulation window. This is helpful when multiple simulations are being 
executed concurrently in different windows. Finding a specific simulation is now possible by inspecting the 
title-bar for the desired ACF file. 
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Improvements to Events

The following improvements have been made to the standard Events available in Adams Car: 

● A new ‘Disengage clutch’ option is available for the Braking and Braking-in-turn events.
● The Frequency Response event is now more flexible when Input Type = Swept Sine, allowing for 

specification of the initial & maximum frequencies, the frequency rate and the event start time. 
● A ‘Steering Release’ option is new for the Step Steer event. Allows user to specify a time when the 

steering wheel is to be released. 

Car True Batch Mode

Past versions of Adams Car could be simulated in ‘batch’ mode, but a requirement existed that the 
computer must have a valid graphics card & graphics environment. In this release of Adams Car the batch 
mode scripting can operate on machines that do not contain graphics cards (as found on ‘compute 
servers’).

The majority of Adams Car functionality will work in this new environment, but some of the utility 
applications such as the Road Builder or Leaf Spring Editor may not yet function properly. To use the old 
behavior for graphics, set the environment variable: HMI_ACAR_LEGACY_BATCH_MODE=1

Improved Flex-to-Rigid Swap

It is now possible to ‘undo’ a rigid-to-flex (MNF Import) operation, replacing a flexible body with a rigid part. 
Previously, a flexible body could have its inertia invariants set to rigid to approximate a rigid part but that 
method required the retention of the (possibly large) mnf file and it also required an Adams Flex license. 
With this new swap behavior, a smaller Adams Solver model can be realized and the Adams Flex license is 
not required. 

Users can simply right-click on a flexible body to find the two options of “Make Rigid (Retain Mesh)” and 
“Make Rigid (Original Geometry)”. The “Retain Mesh” method simply keeps the flexible body in the model 
and sets the inertia invariants of the flex body to approximate a rigid body. Choosing the “Original 
Geometry” method attempts to replace an existing flexible body with the original rigid geometry if it is 
present in the model. The user is prompted for action when mass & inertias don’t match between the rigid & 
flexible bodies, like so: 

 

What’s New   



- 95 -

 

Note:   

Existing *.acar.cfg files from older Adams versions (prior to v2023.2) undergo a 
one-time conversion process to a new format. This new format is not 
understood by previous (v2023.1
and prior) Adams versions, so launching older Adams versions will not reflect 
changes made in the newer format.

For users who regularly switch between older and newer versions, it is 
recommended to save an old-style acar.cfg to a different name (acar_
legacy.cfg) and use the ‘ACar Preferences’ section of the Registry Editor to 
reference this old-style file. Then, simply maintain the default Preference 
setting in newer versions. Refer the article Adams Car preferences, private 
configuration file changes and incompatibilityfor further details.

Adams Controls

New FMU File-Saving Options

Functional Mockup Units (FMUs) exported from Adams now contain two new parameters that control which 
output files are retained when an FMU is run as a ‘child’ from within another process. The new options 
named save_messages and save_results are of type Boolean and will appear as fixed parameters for an 
FMU exported from Adams. Both parameters default to FALSE, but can be set to TRUE in a host 
application to turn on output of the Adams Solver Message (.msg) and Results (.res) files, respectively. 

These new parameters are an easier way to enable saving of these file types. Previously users would have 
to set the MSC_ADAMS_REAL_TIME string parameter to specific keywords; these Boolean parameters 
should be more intuitive. Note that writing of the .res and .msg files requires some computing resources so 
the fastest performance will be when these parameters are set to the default of FALSE. Turn on the .msg 
and .res files when debugging or verification is required. 
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Encrypted FMUs for dSPACE SCALEXIO

Adams FMUs exported to the dSPACE SCALEXIO platform now support the ‘Encrypted’ option. These 
FMUs are intended for co-simulation with dSPACE SCALEXIO; in past releases the Adams model within 
the FMU could be inspected. This new functionality encrypts the Adams (.adm) model, providing a level of 
security when sharing models that potentially contain proprietary information. 

Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI

Marc 2014.1 No support for ACSI

Marc 2014.2*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2015*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”
 

Adams Flex

Improved Flex-to-Rigid Swap

It is now possible, in both Adams View and Adams Car, to ‘undo’ a rigid-to-flex (MNF Import) operation, 
replacing a flexible body with a rigid part. Previously, a flexible body could have its inertia invariants set to 
rigid to approximate a rigid part but that method required the retention of the (possibly large) mnf file and it 
also required an Adams Flex license. With this new swap behavior, a smaller Adams Solver model can be 
realized and the Adams Flex license is not required. 

Users can simply right-click on a flexible body to find the two options of “Make Rigid (Retain Mesh)” and 
“Make Rigid (Original Geometry)”. The “Retain Mesh” method simply keeps the flexible body in the model 
and sets the inertia invariants of the flex body to approximate a rigid body. Choosing the “Original 
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Geometry” method attempts to replace an existing flexible body with the original rigid geometry if it is 
present in the model. The user is prompted for action when mass & inertias don’t match between the rigid & 
flexible bodies, like so: 

 

Adams Machinery

BearingAT: Cylindrical Roller Bearings Without Inner Ring

It is now possible to create cylindrical roller bearings without an inner ring. This applies to bearings created 
directly in Adams as well as those created from a REXS file import. 

Adams PostProcessor

Performance Improvements with Large Flexible Bodies

Models containing large flexible bodies may exhibit performance improvements in the following areas:

● Loading existing animations can be up to 4X faster for some models. 
● Preparing animations for the first time (“memory pre-caching”) can be up to 40% faster. 

Preparing animations need only happen once due to the following improvements made to flexible body 
caching:

● Memory pre-caching will be saved to disk when you switch result set or animation type so that the 
time to prepare the animation is avoided when you return to it.

● Flex body cache files (.fcf) persist from session to session. This means that the work to prepare the 
flex body for animation is saved when you leave a session and reused when you return to the model 
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in a new session as long as the .fcf can be found. This avoids the time to prepare animations in 
subsequent sessions.

Order Analysis Plotting

This is an extension to Adams Post Processor’s 3D FFT capability to allow generation of a 3D plot of an 
Adams result set component signal’s amplitude over RPM slices versus order. The RPM is from a user-
chosen reference rotational velocity Adams result set component. This reference rotational velocity must 
be monotonically increasing or, at least, have an average that monotonically increases.  Adams can pick out 
such averages if, for example, the signal is sinusoidal about an increasing mean as in the case of many 
motor-driven rotating machinery applications.

 

Order Analysis plots can be visualized as either 3D surfaces or colormaps, as shown below, that represent 
magnitude with respect to order and input rotational velocity: 
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Abbreviation Option for Plot Unit Labels

It is now easy to change unit labels in plots to Abbreviations from Full Names. Examples of abbreviations 
for units vs full names might be:
Force: newton vs N
Time: sec vs s
Torque: newton-mm vs N-mm

This setting is found in Adams PostProcessor under Edit → Preferences as shown below: 
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Adams Real Time

New Setup Guide for VI-grade Driving Simulator

A new document has been created that illustrates how to use an Adams Real Time model (exported from 
Adams Car) with VI-DriveSim and the VI-grade DESKTOP Simulator running in SIMulation Workbench 
(SimWB) on a Concurrent Redhawk Realtime OS. See the Adams Real Time documentation, located 
under the ‘Adams Advanced Package’ section of the documentation. 

Tire Performance Improvements & New Capabilities

Models using the PAC2002 tire format can run up to 15% faster in Real Time simulations, as compared to 
the previous version. 

Belt Dynamics and 3D Enveloping Contact in Real Time

Tire models using belt dynamics effects can now run in Real Time. Tire property files that specify belt 
dynamics must be changed to use the new ‘INTERNAL’ option to realize the performance benefits. Any 
simulation in Adams using tires with belt dynamics can be changed from the old settings of:

BELT_DYNAMICS = ‘YES’ OR BELT_DYNAMICS = ‘EXTERNAL'
to the new setting of 
BELT_DYNAMICS = ‘INTERNAL’

As well, tires using the 3D enveloping contact feature now run in Real Time simulations. 

Adams View

CAD Interoperability Version Support 

The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2023.3. 
 

Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R33 Not Supported

CATIA V6 (.3dxml) 2014X → 2022X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 9 Not Supported

Inventor (.ipt, .iam) All → 2023 Not Supported

What’s New   



- 101 -

Format Import Version Export Version

Solidworks (.sldprt, .sldasm) 99 → 2023 Not Supported

Unigraphics (.prt) 11.1 → NX CR 1953, 1957 and 
1969, 2212

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Adams Car

Adams Car Preferences

Setting preferences in Adams Car has been simplified with the new Preferences (Settings → Preferences) 
panel. Past versions required users to edit the *.acar.cfg file in a text editor to persist settings; now it is 
much easier in a graphical user interface, like so: 

 

 

Note:   

Changes made in the Preferences panel get written to the private *.acar.cfg 
file. The location of this file is reported in the Command Window (press F3 to 
open Command Window): 
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Note:   

Existing *.acar.cfg files from older Adams versions (prior to v2023.2) undergo a 
one-time conversion process to a new format. This new format is not 
understood by previous (v2023.1
and prior) Adams versions, so launching older Adams versions will not reflect 
changes made in the newer format.

For users who regularly switch between older and newer versions, it is 
recommended to save an old-style acar.cfg to a different name (acar_
legacy.cfg) and use the ‘ACar Preferences’ section of the Registry Editor to 
reference this old-style file. Then, simply maintain the default Preference 
setting in newer versions. Refer the article Adams Car preferences, private 
configuration file changes and incompatibilityfor further details.

Request Map Editor Updates

The Request Map Editor functionality is now used for both RPC and MAT file export. As such, the Request 
Map Editor and Request Map Activity dialog boxes contain minor cosmetic changes to better support both 
formats: 
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Adams Controls

Allow Additional Files when Building FMUs

Adams Controls can be used to create Functional Mockup Unit (FMU) files. The export process for FMU 
creation has been enhanced to let the user include arbitrary files in the fmu. This is useful for cases where 
the fmu model requires an additional dll or data file, for example, to run properly. There are several ways to 
create an FMU file in Adams View or Adams Car; the ‘Car General FMU Export’ dialog box, below, shows 
the new Add to FMU field that allows users to browse for files that will be packaged into the fmu: 

 

Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI

Marc 2014.1 No support for ACSI

Marc 2014.2* ACSI 2015-2015.1, ACSI 2016*-
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Marc version ACSI supported version

2019.0*

Marc 2015*
ACSI 2015-2015.1, ACSI 2016*-
2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”

Adams Drill

Adams Drill 2022.4 is the Last Release

Beginning with Adams 2023.1, Adams Drill is no longer included in Adams releases. If you have any 
questions about the transition, please contact your Hexagon Account Manager.
 

Adams Linear

FE_PARTs Work with Adams Linear & Animation

FE_PART elements now support Adams Linear animations. In the prior release, the FE_PART worked with 
Adams Linear solutions but animation was not supported. It is now possible to perform Linear simulations in 
Adams with models containing FE_PARTs and view tables for eigenvalues & vibration results as well as 
animate the linearized system. 

 

Note:   
Only the formulation of “3D Beam” for the FE_PART is supported in Adams 
Linear for this release. The “2D Beam” methods will not work with Adams 
Linear for this release. 

Adams Machinery

GearAT: Multi-Gear Shafts

Modeling geared systems having multiple gears on a single shaft that are in contact with other gears has 
has traditionally been a difficult task. GearAT has been enhanced to automatically orient gears in contact 
so that initial conflicts (penetration of gear teeth) are avoided and complex geared systems begin the 
simulation in a suitable configuration. 

Multiple full-flex gear elements can be mounted to flexible shaft elements and oriented into consistent initial 
configurations for a gear system. In the past, this process was laborious and error-prone; in this release 
much of the connection & orientation logic is handled by GearAT. 
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Adams Real Time

Update Earlier Adams Car FMUs

FMUs generated before Adams 2021.3 and contain Adams Car model .adm files need to be updated in 
order to be solved in 2021.3 and beyond.  Due to the elimination of the Adams Chassis product, there is no 
“apresolver” library anymore which may be referenced by older .adm files.  So, please regenerate such 
FMUs from this version or later of Adams.

Adams Solver

Direct Export to .mat (HDF5) Format

It is now possible to export simulation results directly to the Matlab .mat format from an Adams Solver 
simulation. The .mat format is version 7.3, which is an HDF5-based format. The OUTPUT statement for 
Adams Solver now supports the following new option: 

OUTPUT/MATSAVE

This statement can be added to your model in Adams View & Adams Car via the Settings → Solver → 
Output menu picks, selecting the ‘More’ checkbox, then selecting the ‘Durability Files’ sub-category: 

Enabling this setting will export REQUEST elements in the model to the .mat format. Which REQUESTs 
are saved differ like so: 

 1. Adams View models: all REQUEST elements in the model are saved to a .mat file when the 
simulation completes. 
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 2. Adams Car models: if a Request Map file is used (Tools → Requests → Request Map Editor) then 
only the REQUESTs defined in the Request Map file are exported. If Request Maps are not used 
then all active REQUESTs are exported to the .mat file. 

 

Note:   

This release of Adams Python also includes the h5py 
(https://docs.h5py.org/en/stable/ ) module for working with HDF5 files via 
Python scripting, for example: 

import h5py

# Print all keys (result names) found in .mat file: 

with h5py.File(‘somefile.mat’) as f:

 for res_key in f.keys():

  print(res_key

Adams View

Warnings & Errors Now Color-Coded

Warning & Error messages that appear in the Message Window in Adams View & Adams Car are now 
displayed using different colors. It should now be easier to distinguish between the three levels of 
Information, Warning & Error Messages: 

 

CAD Interoperability Version Support 

The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2023.2. 
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Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R31 Not Supported

CATIA V6 (.3dxml) 2011 → 2013X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 8.0 Not Supported

Inventor (.ipt, .iam) All → 2021 Not Supported

Solidworks (.sldprt, .sldasm) 99 → 2021 Not Supported

Unigraphics (.prt) 11 → NX CR 1953, 1957 and 
1969

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Adams Car

Automatic Ride Height Adjustment in Suspension Analyses

To make it easier to set the ride height prior to subsequent analyses, the suspension testrig (__MDI_
SUSPENSION_TESTRIG) now includes a body (chassis) part constrained to ground with an adjustable 
force. The user sets the target ride height, and the body moves up or down during the initial static 
equilibrium phase, prior to the desired suspension analysis.

Background: When you enable Ride Height Adjustment, you specify the target ride height relative to the 
design position. The target ride height is achieved during static equilibrium. In subsequent transient or 
quasi-static, or static analyses of that event, the ride height remains fixed.

The alignment button , when running a suspension analysis, displays a new option for Body Ride 
Height, as shown below:

 

Adams Co-simulation Interface

Supported Versions of Software for Marc Co-simulation

An updated table of the Adams co-simulation Interface supported versions of Marc is shown below: 
 

Marc version ACSI supported version

Marc 2013.0 ACSI 2014.0, 2014.0.1

Marc 2013.1 ACSI 2014.0, 2014.0.1

Marc 2014.0 No support for ACSI
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Marc version ACSI supported version

Marc 2014.1 No support for ACSI

Marc 2014.2* ACSI 2015-2015.1, ACSI 2016*-2019.0*

Marc 2015* ACSI 2015-2015.1, ACSI 2016*-2019.0*

Marc 2016 and later ACSI 2015 and later

* The ACSI 2016 and later versions require a workaround for the case of Adams models co-simulating with 
Marc versions 2014.2 and 2015. Marc 2016 does not require this workaround. For details see the “Special 
requirements to run Marc” section of the Adams product documentation (Online Help) under “Adams Co-
simulation Interface.”

Adams Drill

Adams Drill 2022.4 is the Last Release

Beginning with Adams 2023.1, Adams Drill is no longer included in Adams releases. If you have any 
questions about the transition, please contact your Hexagon Account Manager.
 

Adams Linear

Linear Support for FE_PARTs

Prior to this release of Adams, models containing FE_PARTs could not be used for an Adams Linear 
analysis. This release supports models with FE_PARTs but only in tabular output form. Animation of Linear 
results with models containing FE_PARTs is not yet supported; this will appear in a future release.

Adams Machinery

Romax to Adams Translator: Expanded List of Elements

More Romax modelling entities may now be translated into Adams Machinery components, including:

● Straight / Spiral Bevel Gear types: modelled with the Romax Detailed or Romax Concept 
methodologies

● Hypoid Gear types: modelled with the Romax Detailed or Romax Concept methodologies
● Romax Loading Planetary Gear Set: mapped to equivalent arrangement of Adams PARTs and 

general constraints
● Improved handling of mass properties related to Shaft & Bore dimensions for Romax Detailed and 

Romax Concept gears 

Gear AT and Bearing AT: Consolidation under Machinery ribbon containers

In previous release of Adams, Gear AT and Bearing AT menus were accessible from Machinery ribbon 
each having its dedicated container. In this release, Gear AT and Bearing AT menu buttons were moved to 
reside within the Machinery Gear and Bearing containers, respectively.
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Gear AT: New orientation method for cylindrical gear pair by clearance study

Prior to this release of Adams, Gear AT cylindrical gear elements were parametrized in a gear pair during 
gear force creation by use of formula, so the gear meshing was properly set up. However, this approach 
imposed some limitations when complex gear trains had to be set up, such as planetary stage, gear train 
with idler gear and when a gear shaft misalignment had to be imposed at design position. 
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In current Adams release those limitations are removed by using new orientation method which is based on 
clearance study. In background, Adams creates model to run clearance study of a gear pair using gear rim 
solid geometry to correctly orient the gears. Please note that the process will fail in case there is no 
clearance possible in current gear pair set up.

 

Bearing AT: TeimOrbit Support for Cylindrical and Needle Roller Bearings
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Property files for Cylindrical & Needle Roller Bearings have been consolidated into a single file using the 
TeimOrbit file format. This file format is human-readable and logically structured, which simplifies the task 
of organizing and inspecting property files. Users will now use a single property file of type *.NPF and single 
contact file of type *.NCF (for the needle roller bearing) where previously four files were needed (*.NPF, 
*.NIF, *.NOF and *.NCF for contact). Similarly for the cylindrical roller bearing, there will be now a single 
property file of type *.RPF and single contact file of type *.RCF where previously four files were needed 
(*.RPF, *.RIF, *.ROF and *.RCF for contact). 

If older-style property files are referenced when creating a bearing, the user is prompted to accept a 
conversion procedure that produces the new-style property file. 

The number of rollers is limited to 150 elements and the number of bearings is capped at 50. It is 
anticipated that these limits will increase in the next release of Adams

EMag AT: New Detailed Motor Type 

It is now possible to define a motor element based on magnetic force density data (*.tab) files, typically

produced from a package such as Ansys Maxwell. A high-fidelity EMag AT motor requires the following 
pieces of information:

 1. Common electromotor parameters.

 2. Harmonic Force data files .emh (as a collection of Fourier series , created from the original time-
domain .tab files) for the 4 drive cycles (drive forward/reverse, brake forward/reverse), or optionally 
directly the time-domain .tab files. 

 3. Stator and Rotor FE models as .bdf ( nastran bulk data files).
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Adams PostProcessor

Animation Performance Improvements

Animation performance has been enhanced for models containing large FE_PARTs. In addition, Clearance 
computations in PostProcessor have been improved, specifically:

● FE_PART animation: models containing FE_PART elements with larger numbers of nodes (20+ 
nodes) animate significantly faster; select models show between 3X and 8X speed improvement for 
animation display.

● Clearance computations in PostProcessor show improvement for models containing large flexible 
bodies. Up to 4X improvement has been observed for the computation time required to display 
Clearance results in PostProcessor with select models containing flexible bodies having a large 
number of nodes & modes.
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Adams Real Time

Switching Mini-Maneuvers in Real Time

While running Real Time simulations, the time to switch between mini-maneuvers may result in a large 
runTime spike. This is largely due to initial conditions computations that are executed immediately after 
switching mini-maneuvers. You can dramatically reduce the time to switch between mini-maneuvers by 
setting the environment variable ADAMS_REALTIME_MINI_FAST. 

 

Note:   
You need to ensure that function expressions set on the actuators, such as steering, 
throttle, etc, through the .xml event files are continuous as no initial condition operations 
are performed, otherwise acceleration spikes may occur.

Parametric Support for dSPACE FMUs

Functional Mockup Units (FMUs) created for the dSPACE platform now support parametrics. With this 
functionality, it is easy to change an operating parameter of a model before the simulation and investigate 
different model configurations. When exporting an Adams model as an FMU, users can choose to ‘Expose 
Model Parameters’, as shown below. 

 

FMUs exported from Adams View can have Design Variables, Point Locations & Mass Properties as 
parameters. In Adams Car this list also includes Property Files and User Defined Element (UDE) 
parameters. 

Adams Solver

New INTEGRATOR Setting: ADAPTIVITY

The (default, as opposed to the legacy Fortran Solver) Adams C++ Solver supports a new argument named 
ADAPTIVITY that is intended to make simulations more robust when the integrator is taking a very small 
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stepsize. ADAPTIVITY, which is on by default, relaxes the ERROR tolerance when the integrator stepsize 
is very small and applies to GSTIFF (I3 and SI2 formulations) and HHT. This change has yielded better 
Solver robustness across a range of problematic models.

 

Note:   
The ADAPTIVITY formulation in the (default) C++ Solver differs from the 
legacy Fortran Solver. Users familiar with ADAPTIVITY in the Fortran Solver 
should not assume identical behavior with the C++ Solver

ADAPTIVITY is turned on by default for this release (C++ Solver only) and may be deactivated by setting 
ADAPTIVITY = 0 on the INTEGRATOR command.

Adams Vibration

ODS Animation Performance Improvements

Operating Deflection Shape (ODS) animation performance has been improved, specifically for models 
containing large flexible bodies. The process of creating an ODS animation object can be nearly 2X faster 
for some models. Navigating between animation frequencies can be up to 8X faster for other large models.

Adams View

New Nonlinear Bushing Element

Traditional bushing elements in Adams View have linear force-displacement and force-velocity 
characteristics. It is now possible to create a Nonlinear Bushing in Adams View having nonlinear 
relationships for the individual force components with respect to displacement and velocity. 

This new bushing type can be accessed via the Advanced Bushing element, in the Forces panel:

 

When creating/modifying this bushing a Property File reference is required to define the characteristics. 
Property File contents can be viewed/edited graphically via the Curve Manager:
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AutoSave in Adams View & Adams Car

Adams View and template-based products (such as Adams Car) now provide AutoSave functionality, 
automatically saving the session as a bin file every X number of minutes. This feature must be enabled via 
the ‘Settings & License’ pick from the Adams startup menu and is found under the Shared → Preferences 
node:
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CAD Interoperability Version Support 

The following table lists the versions of the supported CAD formats that can be imported and exported in 
Adams 2023.1. 
 

Format Import Version Export Version

IGES (.igs) 5.2 & 5.3 5.3

STEP (.stp) 203/214/242 P 214

ACIS (.sat) All → R27 Not Supported

CATIA V4 (.model, .dlv, .exp, 
session)

All 4.XX Not Supported

CATIA V5 (.CATPart, .CATProduct) R10 → R31 Not Supported

CATIA V6 (.3dxml) 2011 → 2013X Not Supported

Pro/Engineer part files (.prt, .asm) 13 → Creo 8.0 Not Supported

Inventor (.ipt, .iam) All → 2021 Not Supported

Solidworks (.sldprt, .sldasm) 99 → 2021 Not Supported

Unigraphics (.prt) 11 → NX CR 1953, 1957 and 
1969

Not Supported

JT : JtOpen (.jt) 7.0 → 10.5 Not Supported
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Running Adams Products

Starting Adams Products 122
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Setting Your Working Directory 126
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Starting Adams Products

This sections described how you can start your Adams products on Linux and on Windows.

Starting Adams Products on Linux

The Adams Toolbar is a starting point to using Adams products on Linux. The toolbar is shown below.

 

You can also use the Adams Toolbar to:

● Customize, keep track of, and organize multiple libraries of standard Adams products
● Create binaries
● Manage custom memory models and product preferences

For more information on these or other Adams Toolbar operations, see the Running and Configuring online 
help (from the Help menu in any product, select Adams Help, on the left pane, select Configuring Adams).

To start a product on Linux:

 1. To display the Adams Toolbar, at the command prompt, enter the command adamsx where x is the 
version number, for example adams2022_1.

 2. Click on the tool representing the product you want to start.
 

Note:   

We recommend that you use the Adams Toolbar to start your Adams 
products, but if you want to automate certain operations, use the text-
based Program Menu. For more information, see the Running and 
Configuring online help.
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Starting Adams Products on Windows

You start any Adams product from the Start menu. You can also use the Start menu to:

● Change your license type
● Generate problem reports 
● Set Adams preferences

For more information on these or other operations, see the Running and Configuring online help.

To start a product on Windows:

● From the Start menu, point to Programs, point to Adams 2024.2 , point to the name of the product 
you want to start.

 

Tip:   
Select the corresponding desktop icon for the product, if you installed 
it on your desktop. 

To start a product from DOS shell in Windows:

● Start → Programs → Adams 2024.2  → Command Prompt. 
● An alternative is to add the /bin directory under the Adams installation directory to your user PATH 

environment variable. You can do this via the Control Panel: 

a.  Type environment in the Control Panel search box.

b.  Select the Edit environment variables for your account pick.

 

● Check to see if you already have a PATH variable defined under “User variables”. If it exists then edit 
it, add a semicolon “;” to the end of the existing value, and then add the “bin” directory under the 
Adams installation directory. Otherwise select New..., use PATH for the variable name and add the 
“bin” directory under the Adams installation directory as the value. The default location of this 
directory is:
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Windows Adams:       
C:\Program Files\MSC.Software\Adams\2023_1_xxxxxx\bin
where xxxxxx denotes build number.
 

 

● Once you are done click OK.
 

Note:   

Windows appends your User PATH to the System PATH environment variable, 
so there is no need to copy the existing System PATH variable to your user 
PATH variable. This behavior is unique to the User PATH variable. For all other 
environment variables, a User variables definition overrides a System 
Variables definition.
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Setting Preferences

This section describes how you can set preferences, such as your working directory, graphics setting, and 
memory model size.

Setting Preferences on Linux

You use the Registry Editor from the Adams Toolbar to set a variety of preferences. For information on the 
preferences you can set, see the Running and Configuring online help.

To display the Registry Editor:

● From the Adams Toolbar, right-click any product tool, and then select Change <Product Name> 
Settings.

Setting Preferences on Windows

You use the Settings menu to modify:

● Graphics settings
● Memory model size

To display the Settings dialog box:

● From the Start menu, point to Programs, point to Adams 2024.2 , and then select Settings & License.
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Setting Your Working Directory

During a session in a default or custom product, you can select the directory where you want to place your 
model and output files.

For Adams View, you can set the working directory from the Welcome dialog box. 

To set your working directory:

 1. From the File menu, select Select Directory.

 2. In the dialog box that appears, select the working directory.
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Tool Tips

Tool tips display information about the item the cursor is currently over in an Adams product. The following 
shows the tool tip that appears when you place the cursor over the link geometry tool.
 

To display tool tips:

● Move the cursor over the item in the interface on which you’d like information.

A brief description of the item appears.
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Online Help

To help you use the Adams products, Hexagon provides online help (HTML format). To view the online help 
and tutorials, you can use your default Web browser. An example of online help is shown below.

 

 
 
 

Versions of Web Browsers

For the Adams Help system, all you need is a Windows, Macintosh, or Linux computer running a fairly new 
browser with JavaScript enabled. If JavaScript is not enabled, then the Help set will not display in its 
entirety. 

Accessing the Online Help

You can view help for a dialog box, a product, or for all Adams products. The figure below shows the help 
for all Adams products, called the integrated master site. You can use this site to view any product’s help 
and search across all product help. You can also access release notes for all products, and view the 
documents in Adobe Reader. 

 

Note:   
The PDFs is no longer embedded with the help system from Adams 
2024.2  release. The PDFs made available in the Hexagon Product 
Document Center (https://nexus.hexagon.com/))

 
 

To get help on a dialog box:

 1. Click in the dialog box for which you need help.

 2. Press F1.

Adams launches a browser window that contains information about the dialog box. 
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To get general help on your product:

● From your product’s Help menu, select Product Name Help (where Product Name is the name of 
your Adams product).

Adams launches a browser window that contains the starting point for your product’s online help.

To open the Adams online help from the Adams Toolbar:

● Right-click the Adams Toolbar tool, and then select Online Help.

Your default browser starts and displays the master site for Adams online help.

To open the Adams online help from the Start Menu:

● From the Start menu, point to Programs, point to Adams 2024.2 , and then select Online Help.

Your default browser starts and displays the master site for Adams online help.

Navigating through the Help

The navigation panel on the left side of the Help window displays the help topics for each 
Adams product. Click the closed book icon (  ) to expand, or the open book icon (  ) to 
collapse the entries beneath. Topics with no icon contain no subordinate topics. Use the left (

 ) and right (  ) arrows to page forward and backwards through the help topics.

Left Pane Adjustment

To adjust the left pane size, drag the icon  in the separator as shown below. 
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Note:   The adjustment of the Left Pane is not available in Internet Explorer.

Searching

You can search all the help files in HTML format for a particular product or all Adams products.

The results are shown on the same page below.
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Printing

To print a file:

● In the help system you can select the Print button . to print the topic that you are viewing
● Print the PDF files from Hexagon Product Document Center (https://nexus.hexagon.com/) 

Index

The Index tab displays product specific help in alphabetical list of keywords associated with help topics. To 
view index entries, you can select a letter group to display the entries for that group. When you click on an 
index entry, the related topic will display in the topic frame. 
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Tutorials and Examples
Adams products have a set of tutorials or getting started guides that step you through examples of using the 
product’s features, as well as introduce the basic concepts of the product. The getting started guides are 
online. In addition, many of the products have examples of its features that are stored in Knowledge Base 
Articles. 

You will find links to all the tutorials and examples for a product under its Examples tab.

To access the tutorials and examples:

● From the online help, from the left pane, select Getting Started and select the product that you are 
interested in.

● From the online help for a product, from the pane on the left, select Examples. 
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Supported Versions of Integration 

Products

Support for Easy5 and MATLAB 136

Supported Environments for Adams Real Time 137

Supported Versions of Integration Products 138
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Support for Easy5 and MATLAB

Easy5

This release of Adams Controls is certified to run with Easy5 2024.1 Easy5 version support is subject to 
change. For the latest information, see updates to the Release Guide here:
http://simcompanion.hexagon.com/.

MATLAB

This release of Adams Controls is certified to run with MATLAB 2022b, 2023a on Linux and Windows. For 
more information on MATLAB platforms and compatibility, see:

http://www.mathworks.com/support 
 

Note:   

If you want to co-simulate with Easy5 or MATLAB and you are running Adams 
Controls on one of the platforms that Easy5 or MATLAB does not support, you 
should consider using TCP/IP communication. This allows Adams Controls to 
communicate with Easy5 or MATLAB even though the codes are running on 
different platforms.

 

Important:   

In MATLAB 2022b and MATLAB 2023a on the Windows platform - Co-
simulation with Adams does not support the DIRECT mode for inter-process 
communication. Only TCP/IP and PIPE modes of inter-process 
communication are supported.
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Supported Environments for Adams Real Time

Concurrent SIMulation Workbench

Adams Solver supports Concurrent's SIMulation Workbench® (SimWB) real time modeling environment on 
the RedHawk™ Linux® operating system. In addition to participating in real time co-simulations facilitated 
by SimWB, standalone Adams can be run on the RedHawk Linux operating system. For this release of 
Adams, Adams Solver is certified in the following environment:

● iHawk® running RedHawk Linux 9.2 and 8.4 with SIMulation Workbench Control Center 2023.2-0 
and 2024.1-0.

● The Adams Red Hat Linux 8.8 installer should be deployed on the RedHawk machine.

dSPACE SCALEXIO

Adams Real Time FMUs will run on dSPACE with the SCALEXIO firmware updated to 2021-A. You must 
install the dSPACE Hypervisor extension and configure a Linux-based virtual machine (Ubuntu 20.04/22.04). 
The Adams 2023.4.1 Installation and Operations Guide provides details of the installation procedure.
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Supported Versions of Integration Products

 

Company Product Name Product Version Adams Product Platform (x64)

The Math 
Works, Inc.

MATLAB* 
(The minimum 
features of MATLAB 
required for 
interfacing with 
Adams are 
MATLAB, Simulink, 
MATLAB Coder and 
Simulink Coder)

2022b, 2023a Adams Controls

Red Hat Enterprise 
Linux 8.8

Suse 15SP4
Redhat 9.2 
Ubuntu 20
Ubuntu 22
Windows 10
Windows 11

 

Hexagon Easy5** 2024.1 Adams Controls

Red Hat Enterprise 
Linux 8.8

Suse 15SP4
Redhat 9.2 
Ubuntu 20
Ubuntu 22
Windows 10
Windows 11

 

Functional 
Mock-up 
Interface (FMI)# 

FMU Export Co-
Simulation
FMU Import Co-
Simulation
FMU Import Model 
Exchange

1.0, 2.0 Adams Controls

Red Hat Enterprise 
Linux 8.8

Suse 15SP4 
Redhat 9.2 
Ubuntu 20
Ubuntu 22
Windows 10
Windows 11

 

MSC Software 
Corporation

MSC.Nastran V69.X and above 
Adams Durability

Adams Flex

All Linux and 
Windows

MSC Software 
Corporation

Marc
2005 and above

2003 and above

Adams Durability

Adams Flex

All Linux and 
Windows

Supported Versions of Integration Products   



- 139 -

Company Product Name Product Version Adams Product Platform (x64)

MSC Software 
Corporation

Fatigue 2001 and above Adams Durability
All Linux and 
Windows

nCode FE-Fatigue
Version 5.2 and 
above

Adams Durability
All Linux and 
Windows

ANSYS, Inc. ANSYS
V6.0 and above 

V5.4 and above 

Adams Durability

Adams Flex

All Linux and 
Windows

Dassault 
Systemes, 
SIMULIA 
division

ABAQUS/ADAMS 

Version 6.3 and 
above 

Version 6.1-1 and 
above 

Adams Durability

Adams Flex

All Linux and 
Windows

Siemens Digital 
Manufacturing 
Solutions 
division

I-DEAS Mechanism 
Design

I-DEAS NX 10 and 
above

I-DEAS 8, 9, NX 10 
and above

Adams Durability

Adams Flex

All Linux and 
Windows

ANSYS, Inc. EnSight
10.1.1b (but later 
than 8.2.1f may 
likely function 

Adams 
PostProcessor

All Linux and 
Windows

cosin scientific 
software AG

FTire
Version 2020-3 
22743

Adams Tire
All Linux and 
Windows

 

Notes:   

With regards to compilers, Adams 2023.4.1 officially supports the 
Professional Edition of Microsoft Visual Studio 2017, but the Community 
Edition 2017 has been found to function in the following scenarios (for more 
details on compiler support see Hardware and Software Specifications 
section of the Adams Installation and Operations Guide):

*Function Evaluation and co-simulation mode for Adams and 
MATLAB/Simulink; External System Library (ESL) import of 
MATLAB/Simulink models into Adams.

**Function Evaluation and co-simulation mode for Adams and Easy5; 
External System Library (ESL) import of Easy5 2024.1 

models into Adams.

#FMI co-simulation and model exchange FMUs generated with Easy5 
2024.1
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